Alexa Smart Home Skill V3 is now live!

I am sure exactly what you mean by supporting both v2 and v3 format. The example you provided works fine as it is if you don’t want make any changes. If you want to set Alexa v3 metadata settings just for learning purpose, this is how it would look:

Number BR4_Temp "Temperature [%.1f °C]" (gTemperature, gBR4_Temp, chartpersist, gBR_Temp, gBedroom4Thermostat) 	["CurrentTemperature"] 	{ alexa="TemperatureSensor.temperature", channel="mihome:sensor_weather_v1:158d0002789d27:temperature" }

Keep in mind that you can keep the v2 tag unchanged for other assistant integration but it won’t be proceed by the Alexa skill once the metadata parameter is configured.

Thanks, you answered perfectly I was referring to the v2 way as catorgeries needing to stay as we often have other systems that use those tags.

Now that I see the {} squirly bracketed stuff can be a comma separated list I would guess the below is also valid?

Number BR4_Temp "Temperature [%.1f °C]" (gTemperature, gBR4_Temp, chartpersist, gBR_Temp, gBedroom4Thermostat) 	["CurrentTemperature"] 	{ alexa="TemperatureSensor.temperature" [scale="Celsius"], channel="mihome:sensor_weather_v1:158d0002789d27:temperature" }

I just added the option in the [] square brackets for the scaling to be used.
Can the square brackets be defined anywhere inbetween the {} brackets or must is be along side the ‘alexa=’ definition?

e;g; is this permitted?
Number BR4_Temp “Temperature [%.1f °C]” (gTemperature, gBR4_Temp, chartpersist, gBR_Temp, gBedroom4Thermostat) [“CurrentTemperature”] { alexa=“TemperatureSensor.temperature”, channel=“mihome:sensor_weather_v1:158d0002789d27:temperature”, [scale=“Celsius”] }

Thanks

Paul

No it has to be specified just after the metadata value like in your first example.

Related to the scale configuration, it is now determined automatically using your OH regional settings. So unless Celsius isn’t your default setting, you don’t need to specify that parameter.

Thanks Jeshab,
I am working my way through the documentation, theres a lot :wink:
Well written too.

I am sure I will have more strange clarifications as I read and play :slight_smile: so far after initial issue not knowing about the v3 migration and all my devices (180) failing it has been a great journey.

I have noticed one thing now I come to think of it that may not be the new skills issue but let’s bring it up anyway in case others have seen it too.

When I expose new items to alexa in openhab and then ask her to ‘discover devices’, she always says “no new devices were found” and yet they are added correctyly to her list in the amazon app. Any ideas?

Regards

Paul

Since the v3 update Alexa has not been able to find any new devices. I left it for a couple of days since the upgrade, but always got Device is not responding. So, I essentially removed all the configuration and linking of Alexa to Openhab Cloud and removing the tags and trying the v3 style - but to no avail. I am running on Release 2.4.

Examples from my items.config

Number  FridgeTemperature "Fridge Temperature  [%.1f °C]" <temperature>   ["CurrentTemperature"]        { alexa="TemperatureSensor.temperature" [scale="Celsius"], channel="mihome:sensor_ht:158d00012cc0ba:temperature" }
Dimmer  LoungeDimmer    "ZWave Dimmer [%d %%]"  <slider> (All,AllLights) {  alexa="PowerController.powerState,BrightnessController.brightness",channel="zwave:device:8617eeea:node7:switch_dimmer" }

Perhaps a syntax error? I have 125 items and some of them are image items.

Although I do get many of the these messages below when triggering a discovery from the Alexa app:
2019-08-17 17:12:52.207 [WARN ] [thome.io.rest.internal.DTOMapperImpl] - Field 'editable' could not be eliminated: Can not set boolean field org.eclipse.smarthome.io.rest.core.item.EnrichedItemDTO.editable to null value

and it’s always no new devices found for awhile after that.

My recommendation for 2.4 users is to use the release candidate version of the binding from here. It works fine with 2.4 installations. Or of course, the 2.5 M2 includes the same version out of the box.

will this version be included in OH 2.4 Release version soon?
Because I would like to avoid manual installation of non released components

No. There are never changes to the stable builds.

This is exactly what I discribed before. Ok, it seems all users are getting this.

Actually they went normally again in my app.
All items shows now the correct state.
The only thing I did was: going to sleep :upside_down_face:

1 Like

I have been adding some new thermostat upper and lower items, see below for two examples. I would like to test them, but I am not sure what to say to Alexa to get the values set, can you advise?

Number BR1_Max_Temp 	"BR1 Max Temperature" 				(gBR1_Temp, statepersist, gRoundup_1, gTempMax)		{ alexa="ThermostatController.upperSetpoint" }

Number BR1_Min_Temp 	"BR Min Temperature" 				(gBR1_Temp, statepersist, gRoundup_1, gTempMin)		{ alexa="ThermostatController.lowerSetpoint" }

Thanks
Paul

i’m out of my home i’ll Try as soon as I came back home

For the moment (accessing remotely) same as before devices not responding…

Is there any way to use the old v2 skill that was perfect for me?

I can confirm this. And I also went to sleep… :smiley:

Thanks for the response.
When will the 2.5 version of OH will be released?

No idea.

Hi, sorry for the delayed response, I did the following today 17/08/2019 :
10:11, “alexa turn on Heat recovery”
10:12, “alexa discover devices”
Location: Northumberland, England.
Many Thanks for looking into this.

So, I just switched to OH 2.5.0.M2.
But the Alexa commands are still not working. Still the same behaviour. Devices do not react and searching for new devices doesn’t find anything.

Do I have to do anything else?
I already restarted the system several times with no success.

Do the basic troubleshooting: make sure you have correct tags, check through REST Api if your item names are available.

Edit: disregard this one: “check through REST Api if your item names are available.” This was for the Amazon Echo Control binding :joy:

This Link: https://myopenhab.org/rest/items?metadata=alexa,channel,synonyms&recursive=true
provides me a valid JSON.
I can find my device:

{“link”:“https://myopenhab.org/rest/items/Sofa",“state”:“OFF”,“editable”:false,“type”:“Switch”,“name”:“Sofa”,“label”:“Sofa”,“tags”:[“Switchable”],"groupNames”:[]},

It’s called ‘Sofa’ (Couch) and is a simple switch.

So, it looks fine, right?
It used to work for the last months with this configuration, until the V3 skill has been released.

Same here and it still works, sorry. I did not use the new tagging, still on the old V2 tagging syntax.