Alexa & TargetTemperature not working after 2.2

Hi there,

My alexa lost all items with the tag TargetTemperature after upgrading to 2.2

here my items that worked good with 2.1

i tried hue emulation and the official skill, both the same, alexa dont find the TargetTemperature items

/* Alexa */
Number Alexa_WZ_Heating "Temperatur Wohnzimmer" ["TargetTemperature"] { channel="max:thermostat:JEQ0304609:JMD3008585:set_temp" }
Number Alexa_SZ_Heating "Temperatur Schlafzimmer" ["TargetTemperature"] { channel="max:thermostat:JEQ0304609:JEQ0433159:set_temp" }
Number Alexa_KZ_Heating_Max "Temperatur Kinderzimmer" ["TargetTemperature"] { channel="max:thermostat:JEQ0304609:JEQ0432308:set_temp" }
Number Alexa_KUE_Heating_Max "Temperatur Kueche" ["TargetTemperature"] { channel="max:thermostat:JEQ0304609:LEQ0007061:set_temp" }
Number Alexa_KE_Heating_Max "Temperatur Keller" ["TargetTemperature"] { channel="max:thermostat:JEQ0304609:JMD3011569:set_temp" }
Switch Alexa_WZ_TV "TV Wohnzimmer" ["Switchable"] {exec=">[OFF:/opt/raspberry-remote/send 10011 1 0] >[ON:/opt/raspberry-remote/send 10011 1 1]"}
Switch Alexa_WZ_PS4 "PS4" ["Switchable"] {exec=">[OFF:/opt/raspberry-remote/send 10011 3 0] >[ON:/opt/raspberry-remote/send 10011 3 1]"}
Switch Alexa_WZ_PI3 "Kodi Wohnzimmer" ["Switchable"] {exec=">[OFF:/opt/raspberry-remote/send 10011 2 0] >[ON:/opt/raspberry-remote/send 10011 2 1]"}
Switch Alexa_WZ_StehLampe "Stehlampe Wohnzimmer" ["Switchable"] {exec=">[OFF:/opt/raspberry-remote/send 00101 2 0] >[ON:/opt/raspberry-remote/send 00101 2 1]"}
/* Switch Alexa_SZ_TV "TV Schlafzimmer" ["Switchable"] { channel="silvercrestwifisocket:wifiSocket:f18e62d7:switch" } */

i tried hue emulation and the official skill, both the same, alexa dont find the TargetTemperature items

i have the same issue.
i have openhab 2.2 running in docker on a synology!

TargetTemperature isn’t running with hueemulation anymore. It has been removed. See here:

You can use “Official Alexa Smart Home Skill for Openhab” via

Then you have to use the tag [ “Thermostat” ] for a group and 3 child tags. Like in this example:

Group gDownstairsThermostat "Downstairs Thermostat" (gFF) ["Thermostat"] 
Number Downstairs_Thermostat_CurrentTemp "Downstairs Thermostat Current Temperature" (gDownstairsThermostat) ["CurrentTemperature"] 
Number Downstairs_Thermostat_Target_Temperature "Downstairs Thermostat Target Temperature" (gDownstairsThermostat) ["TargetTemperature"]    
String Downstairs_Thermostat_Heating_Cooling_Mode "Downstairs Thermostat Heating/Cooling Mode" (gDownstairsThermostat) ["homekit:HeatingCooling"]

So there is no other option using Alexa with Hue Emulation anymore?

I don’t like the idea to operate my openhab through any kind of cloud service

Well, Alexa is a cloud service, too.

You can use your personal “openhab cloud service” located in your local LAN. But, it is not that easy to configure. This personal cloud service also receive the commands from Alexa cloud.

That’s true, but I just activate Alexa when I am at home. So I can make sure that „she“ does not mess up my apartment. :wink:

Beside this, my system is solely operating locally with no connection from the outside world (just available through a VPN tunnel).