Alexa V3 API doesn't expose my devices


I run a lot of devices using the V2 api and they all are exposed to Alexa. No try to add new ones with the V3 API, but it doesn’t work. I can’t reach them by Alexa. It can’t find the new devices:

This is my item:

Switch garage_door_state “Garagentor” (gStartPersist) {channel=“mqtt:topic:embedded:garage:door”, alexa=“ToggleController.toggleState” [category=“DOOR”, friendlyNames="@Setting.Garagentor", actionMappings=“Close=OFF,Open=ON”, stateMappings=“Closed=CLOSED,Open=OPEN”]}

This is what myopenhab shows about the rest interface:


If I understand it correct, all V3 infos are missing. Especially the “tags” part is empty.

Somebody with an idea whats wrong here?


EDIT: btw. If I search with Alexa for new devices, sometimes it finds 65, sometimes 70. This toggles as it seems. Don’t know why :frowning:

EDIT2: Just tried to add a v2 device. Also not possible. All devices which are already registered are working well using Alexa. Baaaaad thing :frowning:

The only way I got this working was to use the REST API to set the tags for each item I wanted Alexa to detect.

(Forgive me if that’s obvious. I only installed OpenHAB a few days ago :))

I can’t find devices at all. And I don’t find an solution. :frowning:

I found my issue. The friendlyNames “Garagentor” wasn’t valid. After changing it to “Opening” it worked.