All Items uninitialized?

Hey folks,
i´ve got a little problem with my oh config:
One year ago or so i´ve installed OH with some Items like Phillips Hue, an z-wave-connector, some z-wave items, a samsung tv and a few more.
Everything worked fine, i managed even the homekit to work with oh.
Well, some days ago i had to restart the Raspberry and since the reboot ALL items stay unintialized. Doesnt matter if the item is a z-wave-switch or a hue lamp…
i´ve made an update of all software-modules but nothing changed.
Any hints how to fix this mess?
Thank you!

Platform information:

  • Hardware: RPi 3B
  • OS: openhabian
  • openHAB version: updated today

I think you mean Things, not items. Correct?

It could be a symptom of a failing SD card. Failing SD cards tend to manifest themselves with strange system behavior.

Are there any errors/exceptions logged in openhab.log when the system starts?

yes, i mean things, sorry!
There are no errors, or an exception anywhere… i added now my avr-receiver (denonmarantz-binding) and the receiver is found as “online”. All other things are still uninitialized…
Till the reboot everything worked perfectly, a failing sd-card should throw some errors also before a reboot, or not?

Update: fixed! somehow all bindings are lost at the reboot… i reinstalled the hue and z-wave binding and now the things are online again.
Thanks for your help!

Not necessarily. There have been a number of posts describing weird behavior and no error messages, the root cause of which was determined to be a failing SD card.

Nevertheless, I’m glad you got it sorted out. There have been a number of reports here on the forum of bindings being uninstalled, so you are not alone in experiencing that issue. :wink:

Might be an remarkable coincidence but I had the same issue until i uninstalled (
last hired first fired; amazon echon control) binding.

I had/have problems with their TTS (other thread) and thought an restart might be a good idea.

But what is treating me to answer/ask here is the question: How can such cased be debuged?
Is ::9001 a valuable place?
Should it be set to [debug] and if so how?

Which entries/lines should be visible if everything goes right? (at which time on a pi4 f.e.)
As far as I have seen there were no error (duing uninizialized in the log). Only some rules failed for good reasons and some items changed from previousState → NULL

The only stuff I see, when it is working again fine is that all things change from NULL → previousState

But such log is not satifying.

Greatings Oekel

PS: Using Openhabian and SSH for connectins