All sensors and one switch working but still getting log warnings


(john) #1

RPi 2B+ with OH 2.4 and I continue to comb through the forum in search of self-help with this problem. 3 - ESP8266’s running Tasmota 6.4.1 software reading 2 - BME280 and 1- DHT11 sensors. My office 8266 also has a relay for a future ceiling light connection along with one of the BME280 sensors. I am using the embedded MQTT broker setup as the main connection to the 8266’s

The sensors and relay have been set up in Paper UI and connected to the MQTT broker via Generic MQTT connection. Both sensors and the switch are displaying live data to the Basic UI screen and turning on and off the relay with no problems.
Here is what I have set up in the ITEM file. The channel entries are gotten from the “stacked paper” icon at the end of the CHANNEL entry.

When setting up the channels in Paper UI, I used
Channel type: number

Channel ID: is the sensor name plus T, H or P of the reading type (ex: officeT)

MQTT state topic: tele/location/SENSOR (location being the room the sensor was in
ex: tele/office/SENSOR)

Incoming value transformation: JSONPATH:$.sensor name.sensor reading for the. (sensor name - BME280 or DHT11 and sensor reading is Temperature, Humidity or Pressure
ex: JSONPATH:$.BME280.Temperature)

Switch          MF_Office_Light            "Light"                      <switch>              (MF_Office, gLight)            ["Lighting", "Switchable"]   {channel="mqtt:topic:4e4ef4ae:officeSwitch"}
Number          MF_Office_Temperature      "Temperature [%.0f °F]"      <temperature>         (MF_Office, gTemperature)      ["Temperature"]              {channel="mqtt:topic:4e4ef4ae:officeT"}
Number          MF_Office_Humidity         "Humidity [%.0f %%]"         <humidity>            (MF_Office, gHumidity)         ["Humidity"]                 {channel="mqtt:topic:4e4ef4ae:officeH"}
Number          MF_Office_Pressure         "Pressure [%.0f hPa]"        <pressure>            (MF_Office, gPressure)         ["Pressure"]                 {channel="mqtt:topic:4e4ef4ae:officeP"}

Yesterday, when I went through all of the setups and got everything reloaded with nothing in the channel data, all sensors and switch were working with no log file errors. Then I shut down the software and deleted the log files so I could monitor. Today I came back and got these errors showing up. So I thought I needed data added to the channel. That is when I went in and copied from the “stacked paper” icon at the end of the CHANNEL entry to the channel field.

2019-03-14 15:54:29.238 [vent.ItemStateChangedEvent] - MF_Office_Pressure changed from 977.5 to 977.4

2019-03-14 15:54:29.372 [vent.ItemStateChangedEvent] - MF_Office_Humidity changed from 38.8 to 38.7

2019-03-14 15:54:38.211 [vent.ItemStateChangedEvent] - Time changed from 2019-03-14T15:53:38.041-0400 to 2019-03-14T15:54:38.071-0400

2019-03-14 15:54:38.257 [vent.ItemStateChangedEvent] - Date changed from 2019-03-14T15:53:38.041-0400 to 2019-03-14T15:54:38.071-0400

==> /var/log/openhab2/openhab.log <==

2019-03-14 15:54:38.838 [WARN ] [ofiles.JSonPathTransformationProfile] - Please specify a function and a source format for this Profile in the 'function' and 'sourceFormat' parameters. Returning the original state now.

2019-03-14 15:54:38.871 [WARN ] [ofiles.JSonPathTransformationProfile] - Please specify a function and a source format for this Profile in the 'function' and 'sourceFormat' parameters. Returning the original state now.

2019-03-14 15:54:38.926 [WARN ] [ofiles.JSonPathTransformationProfile] - Please specify a function and a source format for this Profile in the 'function' and 'sourceFormat' parameters. Returning the original state now.
`
``
Someone along the response to this before said that you have to use string instead of number.
So I changed one of the channels to a string and it gave me this error:

```csv
2019-03-14 17:10:09.092 [ERROR] [ofiles.JSonPathTransformationProfile] - Parameter 'function' and 'sourceFormat' have to be Strings. Profile will be inactive.

All the readings are still live and the switch still works but I’m still getting the warnings. I sorry if I’m becoming a PITA about this but I just would like to put this to rest so I can move on. Is it something to do with the entries in the channel entry? If so, what is the correct data I need to put in there? If that’s not it, what do I need to change to get rid of the warnings and correct this?

I greatly appreciate your help on this matter.

John Frankforther


(CM6.5 H102) #2

Have you installed the JSON transformation service and restarted OH?


(john) #3

I think I have went through the setup procedure so many times I can almost do it in my sleep. Lol

Yes I have JSON installed and have restarted OH. I took a week off after trying to make this work for a couple months, thinking I may have missed something or entered the wrong settings. After checking all the posts others have replied to this problem before, I have come to this point where everything is working. I even went through all the ESP’s and reloaded the software and setup the sensors again. I did lose one of the boards as it wouldn’t load the Tasmota software anymore. I’ll look into that later.

I can see the readings change in the log file with no problems. Once I get this figured out, I will add a button to the circuit for a one-press ON/OFF light switch and pack it into a module to replace the normal ON/OFF switch. I have been reading up on the settings that can be changed within the Tasmoto software via the web interface.

Thanks for the suggestion!!

John Frankforther


(john) #4

Update - I shut down OH and deleted the log files. The only things I have in my Items and Sitemap
files are to display the time and date, nothing else. On reboot the very first line to display in the log file is

2019-03-15 13:28:53.340 [WARN ] [.MqttBrokerConnectionServiceInstance] - MqttBroker connection configuration faulty: host : You need to provide a hostname/IP!

So I have MQTT 2.4 loaded, I have the embedded MQTT 2.4 loaded and I have entered all the configuration information, IP address, port #, name, password and anything else I have the information for. I’m not sure why I’m getting this error. Could this be connected to the other errors noted above? Or maybe scrap the Paper UI stuff and figure out how to do this with the text files?

Thanks for any insight.

John Frankforther


(john) #5

I ended up uninstalling and reinstalling the embedded MQTT binding and so far it’s working
KNOCK ON WOOD !!!