AllPlay binding: Looking for testers

The Docker image from here: is based on Debian:jessie. But Debian:jessie misses the GLIBCXX_3.4.21. The way you mentioned works on ubuntu, but not on Debian:jessie because there is no newer Version than GLIBCXX_3.4.20.

I switched over to an ubuntu based image and installed openhab2.1.0-snapshot manually.

But If i run the discovery from AllPlayBinding openhab2 chrashes:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007fbb720ab274, pid=4888, tid=0x00007fbbcd2c8700
# JRE version: OpenJDK Runtime Environment (8.0_112-b16) (build 1.8.0_112-b16)
# Java VM: OpenJDK 64-Bit Server VM (25.112-b16 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  JBusAttachment::Disconnect()+0x4d4
# Core dump written. Default location: /openhab/userdata/core or core.4888

@nignac can you let me know which snapshot version of the AllPlay binding you’re using? E.g. by executing bundle:list | grep AllPlay in the karaf console.
Also, which docker image did you use for the ubuntu version?

If have installed an Ubuntu-Docker image (17.04):

and just translated / executed the commands from the .dockerfile

Output of bundle:list | grep AllPlay
209 | Active   |  80 |     | AllPlay Binding

@nignac Now I’m out. Sorry!

@nignac I can reproduce the issue on a ubuntu VM. Need some time to analyze this and try to find a fix…

@dominicdesu I tried MaryTTS with an Allplay speaker. Do you know about this issue? German voice speed is too fast!

@nignac I have made a PR today which should fix the issue you had (at least it fixed the same issue on my Ubuntu VM). If you’ll install the binding snapshot tomorrow you should get the latest version as far as I know. Would be great if you could try it again.

1 Like

Now it works!
Thank you!

1 Like


Did you have time to implement “multiroom functionality”?

I am late, but I hope I can provide a PR with some first functionality in the next few days…

1 Like

Ok, sounds good! Thanx!

Sorry, wasn’t able to put much time into this recently and therefore unable to make a PR yet.
If you want to try it, you can use this snapshot build: [edit: multiroom now available in official snapshot]

These new channels are available (probably you need to delete and rediscover your speaker things first in order to see them):

| clearzone | Switch | Remove the current speaker from the zone |
| zoneid | String | Id of the Zone the speaker belongs to |
| zonemembers | String | Set the zone members by providing a comma-separated list of device names. (This channel is currently only for setting the zone members. It does not update automatically if the zone members are changed from another source) |

Device name is the name/label your speaker has in OH.

If you have any suggestions for improvements please let me know!

@dominicdesu Sorry, I didn’t recognize this post, I was on vacation for 3 weeks… :slight_smile: I’m going to test it this week!

First of all, thanks for your work @dominicdesu :slight_smile:

I was testing AllPlay’s binding for a while and everything works fine (With two Panasonic Speakers).

But I’ve a little problem. My network is segmented into vlans and OH and my speakers are in different networks, so multicast discovery is not working fine.

It’s possible to specify a fixed IP address for the AllPlay Thing ? (Like in the Chromecast binding)

Thanks, and again nice work :wink:

unfortunately I am not aware of any connection mechanism other than multicast discovery.
Are there any AllPlay apps which are able to find all your AllPlay speakers? If yes, there is probably a way to implement it in the AllPlay binding as well, although I don’t know how. If no, it is probably not possible or very difficult…

@all: By the way, multiroom support is now available in the latest addons snapshot (=PR has been merged some days ago). No need to use the custom build anymore.


I was playing with a multicast proxy (smcroute) and I forwarded SSDP traffic from Allplay devices network to the network where is installed OH.

Once forwarded the traffic, any system in the OH’s network can detect allplay devices (and control them):


But Allplay binding continues without detecting the speakers. But is more extrange, i can see traffic from my OH to Speakers (A connection is stablished from OH to Speaker’s port 2870).

Once forwarded the multicast SSDP traffic from one network to another, OH sees the Speaker, stablishes (and maintains) a connection with him, but does nothing (And other devices and apps in the network can control the speakers without problem).

How i can extract a binding debug log ? :slight_smile:

Thanks again @dominicdesu


as a first step you could enable the allplay binding and allplay library (tchaikovsky) logs: = de.kaizencode.tchaikovsky
log4j2.logger.tchaikovsky.level = DEBUG = org.openhab.binding.allplay
log4j2.logger.allplay.level = DEBUG

@dominicdesu It tried to update to new binding version:

268 | Active   |  80 |     | AllPlay Binding

I get my 2 speakers inside inbox. But when I try to add them as thing I get “ERROR: 409 (Conflict)” and in karaf console:

14:33:00.924 [WARN ] [g.discovery.internal.PersistentInbox] - Cannot create thing. No binding found that supports creating a thing of type allplay:speaker.

What to do?

Hm, this is not an error message from the binding but from the framework. Did you remove the custom build from the addons folder? I’d try to remove the things from the inbox, uninstall the binding, remove the binding from the addons folder and install the binding from the central repository again.
If this doesn’t help, we need to dig deeper…

Edit: Seems like there are other bindings with similar issues: OH2 Kodi: No binding found that supports creating a thing of type kodi:kodi
Possible that you need to upgrade your OH2?

@dominicdesu I’m on an older build #982. I never did use the addons folder. I instead use the addons.cfg. (removing entry: allplay). Then deleting the following: \userdata\tmp\mvn\org\openhab\binding\org.openhab.binding.allplay\2.2.0-SNAPSHOT\ and after this I put entry “allplay” back into addons.cfg. Then the latest Snapshot of the allplay.binding was installed.
I better should try to update the complete build from #982 to #1039. But I’ll try it later…Thanks for your support.:slight_smile:

Now I’m temporary back to | AllPlay Binding. And it’s running again!