Amazon Alexa does not detect all items


I am not sure if it is a problem with Alexa or But it seems that the cloud connection would work. I was using openhab2 in the actual version. I changed something inside my items and rules file and after that I can not detect all (the needed) items.

What I have done was to unininstall the Cloud Connector Service, also the Amazon Echo Control Binding (but I think it was not used to the detect the items), restarted openHAB multiple times, delete all devices which could be found by amazon and searched multiple times for new items. I also changed the system state of these items and inside the Alexa App I deactivated and reactivated the openHAB Skill multiple times, agreed the oAuth access inside myopenhab and so on. Everything does not work.

The following is the example code for the missing items:

Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Morgenroutine             "Befehl Morgen-Routine"             <switch>              (gKonferenz_Amazon_EchoDot_Befehl)           ["Switchable"]         {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Ausgangszustand           "Befehl Ausgangszustand"            <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Wecker                    "Befehl Wecker"                     <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_BadLicht                  "Befehl Badlicht"                   <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_MultimediaLichtBlau        "Befehl MultimedialichtBlau"         <switch>                (gKonferenz_Amazon_EchoDot_Befehl)       ["Switchable"]             {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Gefrierschrank            "Befehl Gefrierschrank"             <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_LinkinPark                "Befehl LinkinPark"                 <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Verstecken                "Befehl Verstecken"                 <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_GutenMorgen               "Befehl GutenMorgen"                <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_GuteNacht                 "Befehl GuteNacht"                  <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Party                     "Befehl Party"                      <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Luefter                   "Befehl Lüfter"                     <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_KuechenLicht              "Befehl Kuechenlicht"               <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_MultimediaLicht           "Befehl Multimedialicht"            <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_IoTLicht                  "Befehl Iotlicht"                   <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Saugroboter               "Befehl Saugroboter"                <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}
Switch 	         iKonferenz_Amazon_EchoDot_Befehl_Meeting                   "Befehl Meeting"                    <switch>                (gKonferenz_Amazon_EchoDot_Befehl)         ["Switchable"]           {alexa="Switchable"}

So as you can see I tried it as first with ["Switchable"] and later with {alexa="Switchable"}. The first one I have used before upgrading openHAB but after upgrading openHAB Alexa also worked fine. I just changed a few of this items, then the new one aren`t detected so I deleted all the devices and searched for all devices. After that the other items disappeared.

Under I can find as example:

link	""
name	"iApplikation_Alexa_MultimediaLichtBlau"
link	""
name	"iApplikation_Alexa_GutenMorgen"
link	"…pplikation_Alexa_Luefter"
name	"iApplikation_Alexa_Luefter"
link	""
name	"iApplikation_Alexa_Meeting"

So it should be found. In general, the Alexa app only shows me all the lamps. Not a single other item is recognized, and there would definitely have to be others in addition to those that I would like to have.

Since I have uninstalled everything and reinstalled addons, several times the usual tips have gone through, I do not know what to do. That was last week already a cramp to get this to work at all.

Hope one can help me. Thanks in advance.

Are you triggering a discovery on the Alexa side after making configuration changes? Are you seeing any errors in the OH server logs?

Yes after making configuration changes I have triggered a discovery on the Alexa side. I only see Philips Hue devices and multiple Echo Dots and Echo Spots. As far as I know, they are also recognized by Alexa independently of the cloud, so the assumption would be correct that everything that should run via the cloud and should be recognized is not recognized.

I do not get any errors.

I can see this:

09:03:44.705 [INFO ] [.io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
09:03:44.712 [INFO ] [.io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = <XYZ>, base URL = http://localhost:8080)
09:03:44.890 [INFO ] [.io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = <XYZ>, base URL = http://localhost:8080)

Well, I have to add that inside it is online.

Have you tried to rollback the changes you made that started this issue? Once rolled back, stagger your changes to find the culprit item definition. Unfortunately, the discovery process can silently fail on the Alexa end when there is a bad configuration.

I have now virtually used the old program code again for the items. But that is not the problem. The problem is due to the configuration. It simply does not recognize anything anymore. Therefore it was stupid to delete all devices at Amazon, if he does not find them again afterwards. Well with the exception of the Echo Dots and Echo Spots and Philips Hue. But Alexa can find them without openHAB. I have deactivated and reactivated the Skill several times, as well as started and stopped openHAB including clearing the cache, as well as reinstalled the binding to and so on. Somehow I can’t get any further. Can not reinstall everything ten thousand times without success.

The most I could think of would be to create a completely new account at Under Applications I have also deleted the “older” oAuth accesses to the Alexa app accordingly, because by deactivating and activating the openHAB Skill of course this is listed several times.

So surprisingly, it didn’t work with the newly created account then either. So with a new account at Maybe I should check a new Amazon account yet?

How exactly does Alexa find the devices? I mean the REST interface via shows the availability of the devices. How do you try to detect them? The whole status changes etc. bring nothing somehow. So we would have to see that an approach can be found in this regard.

I can also rule out a network error. I just reconnected the Echo Dots to the network. Have now written to Amazon support, maybe they know what to do. It’s actually a shame that the whole thing always runs so unstable.

Unfortunately, they tell me that I have really done everything and that I should perhaps contact the developer of the skill.

Have you tried to remove all your existing Alexa configuration and try to discover a single light item?

So it works again. But I can’t explain why. If I had to speculate, it would definitely take more than 5 minutes until it loses settings again or actually resets them. They will keep a low profile about what happens in the background and how exactly.

I more or less did everything as if I were setting everything up completely from scratch. This means that I also disconnected the Echo devices from the mains for more than 5 minutes.