Amazon Dash Button - The capturing for wlan0 cannot be started

Hi there,

i got a small Problem with adding Dashbutons on a Raspberry 3

The Dashbuttons could not find automatic so i have added them manually with the known mac address.

This resulting in the Error Message: “Status: OFFLINE The capturing for wlan0 cannot be started.”

I think the Reason is the way i have added them to my WLAN Network.

I have connected my Raspberry with LAN Cable and reconfigured the build in wlan Interface on the raspi as Accesspoint so there is no need to block the dash button mac adresses on fritzbox.

I followed the Guidance from “ct Magazin 21/2016 Page 174”

This works good as long i use the Python Scripts but looks like this works not with the Binding from Oliver Libutzki.

Possible there could be make a change of the Binding so this works too?

Best Regards from Karlsruhe

Hmm, so I guess you have to listen for ARP requests on the network interface which connects your RPi3 via ethernet to your local network.

Kind regards

Edit: After reading again I got your point. You have a seperate network which is independent of the local network you are connected via cable to, right?

Can you execute this test application?
Just start by using

java -jar pcap4j-sample-0.0.1-snapshot-jar-with-dependencies.jar

Please post the output here.


i used the cable connection (eth0) from the raspi as local network for connecting to internet
and the raspi 3 onboard wlan module (wlan0) as accesspoint for the dash buttons.

And the Output of your Test Application showed me the exact Problem…

pi@raspberrypi:~ $ java -jar pcap4j-sample-0.0.1-snapshot-jar-with-dependencies.jar
8 Devices found:
eth0 (, xxxx:xxxx …) Capturing: DENIED! Message: eth0: You don’t have permission to capture on that device (socket: Die Operation ist nicht erlaubt)

wlan0 (,, xxxx:0:0: …) Capturing: DENIED! Message: wlan0: You don’t have permission to capture on that device (socket: Die Operation ist nicht erlaubt)

A classic “OSI Layer 8” Problem …

As described in:

sudo setcap ‘cap_net_raw,cap_net_admin=+eip cap_net_bind_service=+ep’ realpath /usr/bin/java

fixed it…

It could be a good idea to mark this Step a bit more visible for “heroes” like me :wink:

Or in German: Wer Lesen kann ist klar im Vorteil

Best Regards

Does this fix the problem in openHAB, too?

Yes, buttons are now detected

Dear both of you,

I have the same problem but am less experienced in linux, raspberry, openhab,…
I did all the instructions from here

At “Configuration Parameters” I can select Netzwerkschnittstelle lo (, 0:0:0:0:0:0:0:1) or Netzwerkschnittstelle
eth0 (, xxxx). is the IP of my raspberry.

What am I missing?
The test application does not exist anymore.

I already set up openHAB again twice. The biggest problem is: when I first tested the button, it worked. Then I decided to do a clean setup and now it does not work. :-/

I spent 1,5 days trying to figure it out (an learned a lot, but still it does not work).

Can any of you help me?
Gerne auch auf deutsch.

Regards, Jens