Amazon echo binding TTS / Announcement delay

Hi all,
first of all, yes i know - i’m still on OH2 but indidnt find time for migration to OH3 (last time i did have to many problems with migration)

I created a rule which tells me with TTS whats the actual TV station and whats the actual movie / tv show.
Works fine, but there’s a delay between 40 and 50 seconds.
So if i ask alexa whats the actual tv program i have to wait up to 50 seconds for a answer.
How can i solve this so that i get the answer directly (within next 10 seconds)?

I saw that the rule starts directly and item alexa_TTS receives the Channel information

Alexa_tts changed from to “tvstationinfo”

but the voice output starts 50 seconds later when
Alexa_tts changed from “tvstationinfo” to

I have a similar issue using Alexa to control a device that is not yet integrated with OpenHAB. The time between me initiating a change, OpenHAB passing it to Alexa and Alexa switching the device seems quite long. Could be an Amazon API thing?

If you guys are talking about OH 2.x version of the Echo binding, then Yes, there are lots of issues around this version and the API interface.

I finally bit the bullet and migrated over to OH 3.x because OH 2.x Amazon binding wasn’t working anymore with Last Voice Command channel and the Amazon binding was a BIG part of my smart home.

It took 2 full months to migrate everything over and I can say, it took a long time BUT it’s well worth it. OH 3.x is so much better than OH 2.x.

The Amazon binding works flawlessly like it did a few years ago when Michael created it. There is a new code owner of it now and the code has been improved greatly since then.

Just my 2 cents worth.

Best, Jay

Hi, it is also too slow with OpenHAB 3.2 in my opinion. When I send a command with textCommand, it takes about 12 seconds till the device reacts. That is far too slow. Do someone know why it is so slow? Is it the API or the binding? When I’m giving the same command via voice, the device reacts immediately.

I have a hardware button programmed to send a textCommand via OpenHAB to the Echo Dot. But when it takes 12 seconds, people start asking if the button was pressed correctly or if it is broken… :wink:

Thanks and best regards

Are you running the latest version of the binding which isn’t part of the OH 3.1 or 3.2 default install?

Best, Jay

Don’t know if that fit here. If I trigger an alarm by playAlarmSound it takes almost exactly 5 seconds until the echo really plays it. What I’m seeing from the logs is that the corresponding channel changes immeditately and also the nextAlarm channel is changing to DateTime that is 5 seconds later than the current rpi system time.
Is that simply because the binding sets it like that because to ensure alexa receives the command before the timer should be triggered? Is there any chance to reduce these 5 seconds a bit - e.g. by some config?

Found out about this and I wanted to share in order to keep up to date with the latest Amazon Echo binding.

"If you’re on openHAB 3.2.0 or later, you can add “ ” in the “JSON 3rd Party Addon Service” section in the settings page of the UI.
Once that is saved, go to the bindings page and you’ll see a new section with the 3rd Party Addons. You’re looking for the SmartHome/J variant of the Amazon Echo Control Binding.
Be sure to uninstall the regular one before you install this one!"

Best, Jay