AmazonEchoControl Binding

Hey,

I have a problem with the Amazon Echo Control binding.

First, I created the Amazon Thing… next step was to open the URL of the AlexaEcho Skill http://openhab:8080/amazonechocontrol/

When I try to login, i will immidietaly get to the next page, where my amazon account needs to verify the application.
-> now my problem, the website refreshes automatically in around 5 seconds.

the email -> which i need to accept doesnt come that fast… and when the website is refreshed it generates a new verfiy key which i also need to accept by email…

i didnt figure out, why the website refresh automatically and i cant stop it…
Did anyone else had this problem before or can help me with that ?

Did you enable 2FA for your account ?

Hey,

no, the 2FA is not activated.
The verified field is just to make sure that’s not a scam program / browser.

According to others that reported the same issue enabling 2FA solves the problem.

Okay, well I only find issues where users need to deactivate the 2FA :thinking:

Anyway, I activated it.

But the problem still the same…
so I tried a diffrent Browser, now i use Internet Explorer.
Which doesnt refresh automatically.
When i logged into the webpage, I am able to verify the access with my Email.

But, when i approve it nothing happend -> there is a little button “already activate click to refresh”
After i clicked on it, i get thrown to the mainpage and must login again.
This error occurs all the time.

When i understand the binding correctly, now i should get a message like “Login successfully”

Any ideas left ? :upside_down_face:

E.g. Preview and Beta: Amazon Echo Control advices to enable 2FA.
One mesage in the same thread ( Preview and Beta: Amazon Echo Control ) points to instruction on how to execute a reset in case of login problems.

thanks for the topic.

but it doenst work as well.

amazonechocontrol listAccounts
“command not found”

i reinstalled the binding and created a new amazon account.
The command is still not found over the console.

hmmm, this is very strange.

I’ve also tried the experienced user function and created a thing directly in the .thing file

Bridge amazonechocontrol:account:account1 “Amazon Account” @ “Accounts” [discoverSmartHome=2, pollingIntervalSmartHomeAlexa=30, pollingIntervalSmartSkills=120]
{
Thing echo echo1 “Alexa” @ “Living Room” [serialNumber=“SERIAL_NUMBER”]
}

which also doesnt work -> Serial number correctly filled by myself.

This has to be a problem with the amazon login.
I did try the 2FA and also without 2FA.

just to make sure as you did not explicitly mention where you entered the command:
did yo enter the command in the karaf console and not on the command line ?

u are right, my fault.
I log into the normal command line.

I’ve tried to open the SSH with karaf@ipadressraspi -p8101 but of course, he tells me my password is wrong… so I found a few topics:
https://community.openhab.org/t/karaf-console-access-denied/38246

but the solution is not working for me, the file does not exist at my openhabian.

https://www.openhab.org/docs/administration/console.html
is not helping as well, or I am not able to understand it correctly.

I thought the file has to be the default included

openhab = (haboben) or something like that

I use openHAB 2.5.1-2 (OpenHABian)

As long as you did not change the defaults then login to your Pi then do:

ssh  -p 8101 openhab@localhost

Did you try that ?

ssh openhab@myIP -p 8101 worked for me, thanks ! :slight_smile:

First, I checked all available accounts with:

amazonechocontrol listAccounts

-> no account found
So i created a new amazon account thing and tried to log in
-> same issue as before with the login
BUT the command:

amazonechocontrol listAccounts

did found my .thing account…

Thing-Id: 843ff691 (‘Amazon Konto’)

So i tried to reset it with the help of your replied topic -> reset works fine
Again tried to log in


Same notification as before and still cant log into after i approved the notification.

very strange…

As far as I understand https://www.amazon.com/gp/help/customer/display.html?nodeId=202073820 you have to use either SMS or an authenticator app for two step verification ( 2FA ).
Email is not listed there.

correct, but this is not the 2FA.
It’s just a notification when amazon think that I got hacked or something like that.
It would be fine when I could deactivate this…

I activated the 2FA with SMS and also with app -> tried both.
When i log into my amazon account with the retail link I need to log in with the “correct” 2FA in my case -> SMS

I dont know why this notification pop up everytime :thinking:

I had the same issue. activating 2FA and updating OH & the Binding to 2.5.10 fixed it for me.

1 Like

oh well…^^
I think “never touch a running system” is the case for me.
Then I bury this topic and live with that :slight_smile:

Thank u anyway guys

I’ve updated OH to 2.5.10 and activated 2FA again.

Still not possible to login.
Same behavior as before, the Log-In Site refreshs nearly instantly and i still need to approve my login with an Email Notification (No its not the 2FA -> 2FA is over my App and is working correctly when i log into amazon via retail link)

Any ideas left now :open_mouth: ?