AmazonEchoControl - Play Alarm Sound not working

Hello Openhab-Community,

I am currently changing all my scripts from Openhab2 to Openhab3 and renewing them. Now I’m stuck with my alarm system and would be grateful for your help!
I have a number of Alexa Echos in the house that should trigger a “PlayAlarmSound” when a burglar alarm is triggered.
I have triggered before the items with the following rule …

sendCommand(Echo_OG_Gaestezimmer_PlayAlarmSound, 'ECHO:system_alerts_atonal_02')
sendCommand(Echo_EG_Wohnzimmer_PlayAlarmSound, 'ECHO:system_alerts_atonal_02')
sendCommand(Echo_OG_Schlafzimmer_PlayAlarmSound, 'ECHO:system_alerts_atonal_02')

In my new script, I use the same command …

 sendCommand(Alexa_Wohnzimmer_Show_PlayAlarmSound, 'ECHO:system_alerts_atonal_02')

No alarm sounds appear …
The log entries give no informations where the problem could be …

2022-10-18 21:47:20.162 [INFO ] [openhab.event.ItemCommandEvent ] - Item ‘Alexa_Wohnzimmer_Show_PlayAlarmSound’ received command
2022-10-18 21:47:20.163 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item ‘Alexa_Wohnzimmer_Show_PlayAlarmSound’ predicted to become
2022-10-18 21:47:20.163 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘Alexa_Wohnzimmer_Show_PlayAlarmSound’ changed from ECHO:system_alerts_atonal_02 to
2022-10-18 21:47:20.907 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘Alexa_Wohnzimmer_Show_NextAlarm’ changed from 2022-10-19T21:47:06.048+0000 to UNDEF

On the item the change was successful but the alexa not respond with any sound …

Even when I try to change the sound directly in the openhab UI no change happens.

I have tried this appearance on two alexas now with the same behavior. Do you please have any idea how can I solve the problem?

Thanks for your help :slight_smile:

I had the same issue, could not solve it and only after I reinstalled my system (for another reason) it was working again.

Do you run your OH2 and your OH3 in parallel? Sometimes I get similar behaviour on my alexas, if there’s two connections in parallel?
If so, try to deactivate the OH2 amazonechocontrol and restart the binding on OH3 to see, what happens.

I have the same issue, but at least for me it has nothing to do wih OH2.
But the PlayAlarmSound is not working for me either, it has worked a couple of days ago though, although I did not change any setting whatsoever since then.

Funny thing though, I noticed that every time I trigger a “PlayAlarmSound”, the “NextAlarm” item is set to a time exactly 24 hours in the future, but no idea why. I checked in the Alexa app, but didn’t find any setting that alarms are set in 24 hours.

Does anybody have the same issue or knows why this happens?