An I/O error has occurred while writing

Hi guys,

Can you suggest what could cause this error:

2019-09-02 18:16:17.981 [ERROR] [ersey.server.ServerRuntime$Responder] - An I/O error has occurred while writing a response message entity to the container output stream.

Caused by:

Caused by: Broken pipe

OH seems to be working without any issues. I lately only added a new sensor data to sitemap, which should not cause this.
Reading in forums I suggested also an issue with Alexa? Tried to disable the skill but no change…
Also it doesn’t look like there is a problem with sitemap config.
Also all desired bindings are normally installed.

Tried to restart service, reboot machine. The computer is quite powerful, a lot more than my previous RPI3.

Do you have any other suggestions?


Often associated with a GUI interruption, e.g.closing a browser or app, or rebooting the host end.

1 Like

Ignore, happens often on broken connections especially to my.openhab

Yeah, I guess so. It’s just interesting it appeared only recently.

I suspect it could also be caused by your firewall (or NAT router) that closes tcp connections prematurely causing this error. Chances are there is no code logic to trap this and recover nicely from it on OH side.