And after trying again still no setup

I tried a lot of different HAB applications but I really like to use Openhabian. But I still can not get this installed on my Rasberry3+
I tried wired it did not work. Can’t get an IP address. Tried Wifi, still can’t get a IP address.
What am I doing wrong?
Searched here and read everything with openhabian.conf but I find no answer.
error is always ending that I can fill in the login and password but it states that there is no connection en ends in an error.

There is something off or wrong with the configuration of your router. If you don’t get assigned an IP address when directly plugged into your router then it is unlikely that it would work over wifi. Do you have DHCP turned off on your router?

This problem is outside of the scope of openHAB and openHABian. You should search Raspberry Pi forums as well.

I can connect with every device, both wired and wifi. The Pi connect when I tried the other openHAB version from HomeAssistant. But I can not get openhabian to work.
With all due respect therefor I don’t think it is the Pi that is wrong nor my router. My guess is that it has something wrong in the openhabian.conf. I just do not know what.
But I will use your suggestion to look on Pi fora also. Thank you

There is nothing in openhabian.conf that would affect the Pi’s ability to acquire an IP address when the Ethernet cable is plugged in. The first boot script literally does nothing but echo out a log statement:

echo "$(timestamp) [openHABian] Setting up Ethernet connection... OK"

When the Ethernet is plugged in, openHABian doesn’t actually do anythin to set up the network. It just lets Raspbian do it’s thing like it does if you downloaded Raspbian Lite from the Raspbian website.

you can see for your self everything it does here.

A little better but still stuck. I am working on a connected Ethernet connection.
This connection works with my printer and laptop. So I am sure it is good.

All goes well up to “started openBSD Secure Shell Server” and then it hangs itself.
Whatever I do how long I wait no progress at all.
Any idea what I can try?

Do you have a valid power supply for the Pi? I hard a terrible time with my Pi when I first got it as I thought a old school phone charger (micro usb 1.5 one), I could only have the HDMI cable and a usb keyboard plugged in and it flashed a cartoonish lighting bolt in one of the top corners. As soon as I purchased a official power supply it ran a lot better.

I use the original power supply that came with the Pi. So I assume that is the right one.
The entire package came as a complete set, Pi 3+, case and power. Can it be that this is not the correct one?

It should be the correct power supply then, I bought mine in pieces and learned lessons. :slight_smile:

I looked it up and my issue was that the old phone chargers don’t have the required amount of amps that the Pi wants; their doco - states 2.5 amps.

Does a static IP address get the system online?

For kicks, have you tried a cat5 cable directly to the switch/router to rule out wiring/wall jacks/etc? If you are plugging directly in, have you tried a different cat5 and different network ports? I’ve had odd experiences with cables in the past…usually ones I crimped myself in a hurry or behind desks and doing acrobatics as the executives desks are super heavy to move (and heaven forbid you move anything around on their desks).

Two other considerations have you tried a different version of openhabian?

So I tried a lot of your suggestions but I am sorry to say nothing so far. I thought!
Don’t know what did the trick but I am one step further.
It seems all is setup. The Pi starts and runs through the first stages.
But then it halts again.
Either Wifi or cabled I get the folowing:
starting the openhabian inintial setup
Storing configuration … OK
Changing defaultusernamen and password…Skipped
Setting op Wifi connection…OK
Ensuring network connectivity… FAILED

I was not able to connect to the configured WiFi
Please try again with the correct SSID and password

Cabled it mentions that i gets acces also.
I use the right SSID and password. I am sure cause all other devices are connected. :slight_smile:

I am getting desperate. Why is OpenHABian so difficult to setup? The colleagues at Home Assist made it easier. (They have other things I did not like!)
Hope you can help me out here.

Are you able to skip this setup and reach a CLi, based on what you posted its difficult to determine if you have a DHCP issue or a AP association issue? Although the wired connection also failing its seems like a DHCP issue.

Have you tried a static IP?

It worked. Wireless did not. And after removing all devices, switches and so forth from the router and connecting only the Pi it worked. Really no clue why but maybe something hindered the connection.
After that I could configure the wireless and now it all seems good.
Thanks, your suggestions made me go on.

Fantastic, glad you got up and running!