Android KitKat client compatibility Issue

  • Platform information:
    • Hardware: Raspberry Pi 3b
    • OS: openhabian-pi-raspios64beta-v1.6.3b.img.xz
    • Java Runtime Environment: The one contained in version above
    • OpenHAB openhabian-pi-raspios64beta-v1.6.3b.img.xz
  • Issue of the topic: Openhab Android KitKat client compatibility
  • Please post configurations (if applicable): N/A
  • If logs where generated please post these here using code fences: N/A

I just build an oh 3 node to orchestrate home automation in my house.
I have an old Chinese android tablet laying around (Digiland 1010q) that i thought it would be perfect for Using the OpenHab App HabPanel feature…
Problem is , it is running Android KitKat. the last OpenHab App update for KitKat is 2.11.0, and it does not look like it can connect to the node (http 500 error). Any ideas on how can i work around this? Ideally, I would just run HabPanel on the tables, just as a remote control

Thank you for your help and comments


Please edit your title and tags to remove “1.x Compatibility” and specify that you’re talking about the openHAB Android app (as opposed to the HabPanel Viewer app). The more specific you can be in your posts, the easier it’ll be for us to help you.

Have you confirmed that the newest version of the openHAB works on another Android device? It’s best to confirm that before we assume that KitKat is the problem.

It’s also possible to run HABPanel in the browser on the tablet instead of using the openHAB Android app. That could be a work around as well.

For the most part though new versions of the Android app only support versions of Android back so far. It’s not possible to maintain complete backwards compatibility and it’s not feasible to back port every change to the older versions.

IIRC, between version 2.11 and the current version of the Android app, there was a complete rewrite into Kotln from the original Android Java.

1 Like

Just made your recommended modifications, thanks for that.
You mentioned the HabPanel viewer up.
Is that app supported by the OpenHab community? I saw in the app store that it is not published by OpenHab.

Thanks for the background.
Yes, for now, I found and app called fully Kiosk that I decided to run with, at least in the mean time.
I will be seeing if I can upgrade this tablet to at least lollipop (Minimum requirement for the current OpenHab app). Unlikely though, since the manufacturer has not updated the image since 2015, and the only other alternative is to try to build the image myself.

Fully Kiosk works fairly well. A lot of people use it here.

HabPanel Viewer is supported by a community member. It’s no longer updated on Play Store, but if you use the link from my post, you can get it directly from GitHub. You can also install it via F-Droid.

Funnily enough I was also searching on this same topic because I received a Samsung Note 10.1 (GT-N8020) running Android 4.4.2 (Kit Kat) and was getting the 500 error as well when trying to connect it to OH.

When I first opened the OH app after installing it, it did its auto_discovery thing which populated the IP address but constantly returned an error. Strangely also the auto-discovered port wasn’t correct. Changing the port only didn’t remove the error in the setting page, so I ended up removing the IP address and the credentials and then added them back again (including the correct port) and now it seems to work correctly. Not sure which version of the app I downloaded.

The exact steps I followed were that I tried first with only the IP, then I added the port and got a 401 error and then I added the credentials and it worked.

Just thought I’d post this in case it helps.

That is good feedback, thanks a lot.
It does raise a couple of questions
-Installing OH app on last version does not really require any credentials…why would it require them for the 4.4 version?
-When you mention that it discovered “the wrong port”, you mean it discovered 8443 instead of 8080? That happens also on the last version, and the app is still able to connect.