Android remote access stopped working in a day

Installed on Rpi3, Installed latest version a week back The remote access dashboard was working all day yesterday in my android mobile. But today morning it cant detect the local server. But the gadgets are working when I tried switching on and ff a switch using Alexa connected thru Cloud. Its just that the Mobile App cant connect to dashboard.

But when I restarted the Rpi3, the mobile app started working again. Any idea why is this happening?

Just now noticed that the android dashboard stopped working again, this time within an hour after restarting my Rpi3. And I tried getting into paperUI and its not responding too.

Sorry for multiple messages, But now noticed that paperUI is working, No errors in log, But Android Dashboard not working :frowning:

One more update, Cloud dashboard is working in Android App, but local is not working n Android app.
So to summarize

Dashboard in Android works for sometime in Androd app and then suddenly stops working. PaperUI is working, And when Android app is connected to Cloud (Remote) server its working. No error in Logs

Need Help in identifying this issue

Double check your app settings.

Is the phone on your LAN all this time or is there some swapping between LAN and cellular networks?

Do you see any errors in openhab.log? Particularly around the time that the Android app stops working.

When the Android app stops working, can you bring up BasicUI in the phone’s browser?


Yes the Phone is on LAN all the time. No error in openhab.log and yes I can bring up the Basic UI in the phone browser.

Now I have added the remote server details in the App and now it connects to the cloud/remote server when it cant connect to local server. Thats the workaround I have found out. But still not able to figure out why it cant connect to local server when the cloud is working properly.

At this point I think you need to file an issue at