Announcement - openHAB-iOS 2.3.1 is released

Please note that we just released a new version of the iOS app.

Here is the feature list


  • open­HAB-iOS is now also han­dling dy­nam­ic map­ping (rel­e­vant for in­stance for avm­fritz, spo­ti­fy, z wave bind­ings)
  • Slid­ers up­date in real-time (if set in Set­tings)
  • Add con­nec­tion set­ting called “Al­ways send cre­den­tials” which con­trolls whether HTTP Ba­sic Auth cre­den­tials should be sent for re­quests re­gard­less of whether a chal­lenge was is­sued by the server. Un­der stan­dard server set­ups, this op­tion should be turned off. This op­tion can be turned on for servers which don’t re­spond with a 401 chal­lenge when cre­den­tials are re­quired.
  • Han­dling con­nec­tion type changes
  • Sup­port for more HTML col­ors
  • Change of site to up­date list of sitemaps
  • Up­dat­ed client cer­tifi­cate han­dling to im­port and store the full cer­tifi­cate trust chain in the key­chain and in­clude it in the TLS hand­shake with the server. This ad­dress­es the is­sue where a client cer­tifi­cate may have been is­sued by an in­ter­me­di­ate CA but the server does not have full chain con­fig­ured to val­i­date the client cer­tifi­cate.

-Side menu pre­sen­ta­tion
-Chart leg­end cor­rect­ed - leg­end was still dis­played if set to false
-Ad­just­ed UTI set­tings to get client cer­tifi­cate im­port work­ing on iOS 13.
-Han­dling of blank sitemap la­bel
-Em­bed­ded im­ages caus­ing in­fi­nite loop
-“Ig­nore SSL Cer­tifi­cates” tog­gle not only con­sid­ered at start­up

We are also getting closer to an Apple watch app. Please be patient or contribute to the development on github



thanks for all your work on this!

Since using this latest version of the app I find that notifications do no longer arrive in the app. When I log into website I do see these notifications.
In the app the list of notifications keeps empty.

I went back to an earlier version. Same issue. Probably related to a server side issue

Hi Guys, I have the same problem with notifications, I don’t receive anything on iOS, but I can see in the notifications log. On android mobile is working fine.

I’m using the latest testflight version and I’m facing the same issues.
Looks indeed like a server side issue

Hi There,

I see the notifications in the side tab but do’t get push notifications any more, since the update…

Just let me know if somebody was able to find a workaround or the issues has been solved.

And of course than k you for the work!


I have the same error.
Does somebody known the solution?


Since yesterday I am receiving push notifications again!
Thanks for fixing! :wink: