Another Aeon Gen 5 Issue - No Device

Hi all, well this is frustrating. I was on a roll and then…

So i have a basic z-wave GE Switch. I have the Aeon Gen 5 USB Stick. Wired the switch and connected it to the Aeon and voila! it showed up in openHab Admin under the bindings/devices! perfect! this was using port USB0. I added an item into my items file and restarted openhab. went back into admin and my device was gone. what? yup, gone.

so then i go through the port searching. i find that it is not USB0 any more it is on ACM0. Ok, no worries. Update the config. restart. admin shows that i am looking at ACM0 in the bindings. but still no device.

so what is the next step? i tried the heal network and it gives that error sending to server.

thanks in advance!

This is going from bad to worse! I factory reset the zstick and am trying to re-pair with the switch. now it wont pair! grrrrr…

Ok, so I fixed my pairing problem with the information here:

but still not seeing the device in my admin.

can you include any of the log? What you should see is the binding showing that it found 2 devices (at least), device 1 is the stick, and device 2 (or some number higher than 1 anyway) is your GE switch. What ever node number it says is what you will want to reflect in your zwave.items file

A few notes about the Gen 5 z-stick. It shows up as /dev/ttyACM0 this is the correct device. The S2 stick shows up as /dev/ttyUSB0. There is a technical reason for this, but not important to get you going. If you factory reset, your device node ID will restart at device 2 and increment as you add devices. It will never go back down or use empty slots unless you factory reset again. Z-wave in general, it never hurts to exclude a device before adding it to your network.

The log is the important part here. Give it a look, see what your device node IDs are, and then adjust the zwave.items file to reflect those node IDs. Here is a typical entry for a GE switch:

Switch  OutsideWalkIn           "Outside Garage walk-in light"                  <light>        (ALL,lights,outLights,oA)    {zwave="12:command=switch_binary" }

In this case, the node ID is 12. Hope this helps!

Thanks Jim! Was not sure which log to look in but I found this in the syslog from yesterday:

Feb 3 20:58:46 raspberrypi kernel: [ 2694.206481] usb 1-1.3: New USB device found, idVendor=0658, idProduct=0200
Feb 3 20:58:46 raspberrypi kernel: [ 2694.206535] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Feb 3 20:58:46 raspberrypi kernel: [ 2694.209633] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
Feb 3 20:58:46 raspberrypi systemd-udevd[11060]: failed to execute ‘/lib/udev/mtp-probe’ ‘mtp-probe /sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3 1 8’: No suc$

This was the last time I tried it.

Let me know if there is something else I should be looking at. There is alot in the log from yesterday.


That looks okay, the device is getting identified by the operating system. The log that should tell us more is called openhab.log. Its location varies on how you installed openhab. If you extracted a zip, it will be in the logs folder where you extracted. If you installed from apt-get, I think you can find it in /var/log/openhab

awesome, found the log! lots in there so not sure what i am looking for. i found this that looks interesting…

2016-02-03 20:15:30.011 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, port = /dev/ttyACM0
2016-02-03 20:15:30.013 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, healtime = 2
2016-02-03 20:15:30.017 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been started
2016-02-03 20:15:32.377 [INFO ] [b.z.i.protocol.ZWaveController] - Starting Z-Wave controller
2016-02-03 20:15:32.378 [INFO ] [b.z.i.protocol.ZWaveController] - Z-Wave timeout is set to 5000ms. Soft reset is false.
2016-02-03 20:15:32.379 [INFO ] [b.z.i.protocol.ZWaveController] - Connecting to serial port /dev/ttyACM0
2016-02-03 20:15:32.460 [ERROR] [b.z.i.protocol.ZWaveController] - Serial Error: Port /dev/ttyACM0 does not exist
2016-02-03 20:15:34.557 [INFO ] [.myopenhab.internal.MyOHClient] - Connected to my.openHAB service (UUID = edbafc34-ad1a-4a94-b040-460ffbbe413d, local base URL = http:$
2016-02-03 20:15:35.019 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been shut down
2016-02-03 20:15:47.339 [ERROR] [i.h.s.p.PersistenceModelHelper] - Can’t open model file ‘myopenhab’

Which version of OH are you using?

hi chris, 1.7.1.

Sorry, can I ask why you are on this version and not upgraded to 1.8?

This looks like a permissions issue. The user that is running openhab needs to be a member of the group (in /etc/groups) of the group tied to the device. This is usually something like “dialout”

Get the group from the device by issuing this command at a shell prompt: ls -l /dev/ttyACM0

That will show you the user and the group. After that you will need to edit (with sudo) /etc/groups and add the user running openhab to the group that matches from the ‘ls’ command. After that, try restarting again.

I think I just fell at that point right before the upgrade came out and i have not upgraded yet. Assume that is not a huge issue and there is a wiki or some posts on it?

Hey Jim, this is what I get with that command:

crw-rw---- 1 root dialout 166, 0 Feb 5 10:04 /dev/ttyACM0

Looks good. Edit /etc/group and add the user running openhab to the line for dialout

It may end up looking something like this:


remember you will need elevated privileges to save the file (use sudo to run the editor).

Save the file and restart. That error should be gone.

You can upgrade to the zwave binding 1.8.1 without upgrading the rest of oh1.7 had been my experience. That’s the way I’m running due to some issues with 1.8 I’m having

Hey jim, that didnt seem to fix it. after thinking through this, since i dont have anything setup yet i think i will go ahead and wipe this thing and load 2.0. figure i might as well start with that and maybe it will fix my issues too.

thanks for all the help guys!

So I got back on this today. Progress but not progress. I decided to stay with 1.8. So I did a clean install.

Jim, I updated the dialout line it now reads dialout:x:20:openhab where it read dialout:x:20:pi. Hope that correct.

I am now using the zwave binding 1.8.1.

I used the Aeon Gen 5 and excluded the switch and then repaired it. Then plugged it back into the pi.

How do i find the nodeID? I found this in the bindings wiki: To find out your devices nodeIds either look at the startup log of openhab. Where is the startup log? I dont see one in my log folder. Then what am I looking for in that log?

Will is show up in habmin without the nodeID?


I found this in the syslog. Not sure if it helps or not:

Feb 9 02:05:05 openhab kernel: [ 2239.668581] usb 1-1.3: USB disconnect, device number 4
Feb 9 02:07:37 openhab kernel: [ 2391.985726] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
Feb 9 02:07:37 openhab kernel: [ 2392.089004] usb 1-1.3: New USB device found, idVendor=0658, idProduct=0200
Feb 9 02:07:37 openhab kernel: [ 2392.089035] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Feb 9 02:07:37 openhab kernel: [ 2392.090366] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
Feb 9 02:07:37 openhab systemd-udevd[9365]: failed to execute ‘/lib/udev/mtp-probe’ ‘mtp-probe /sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3 1 6’: No such file or directory

more log data from tonight. i have totally verified the usb is on AMC0. still get this error when i restart openhab:

2016-02-09 03:30:25.048 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, port = ACM0
2016-02-09 03:30:25.050 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, healtime = 2
2016-02-09 03:30:25.055 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been started
2016-02-09 03:30:25.158 [INFO ] [b.z.i.protocol.ZWaveController] - Starting Z-Wave controller
2016-02-09 03:30:25.161 [INFO ] [b.z.i.protocol.ZWaveController] - Z-Wave timeout is set to 5000ms. Soft reset is false.
2016-02-09 03:30:25.163 [INFO ] [b.z.i.protocol.ZWaveController] - Connecting to serial port ACM0
2016-02-09 03:30:25.246 [ERROR] [b.z.i.protocol.ZWaveController] - Serial Error: Port ACM0 does not exist
2016-02-09 03:30:30.057 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been shut down

@boilermanc , the entry in the groups file looks good if the user running openhab is ‘openhab’. If you are on a pi, chances are the user is pi. You might consider making the entry as such to cover either case:


This should give us everything we need to know about the device openhab will use. The last catch is that when you change the group file, you need to log out and back in for the group to be picked up. This is the case if the user running openhab is the user you are logged in as. You could even restart the pi to make sure any system users also have the modified group picked up. Try this and see if the error for not finding the port goes away after restart. Thankfully, these steps involving the group file should be one-time.

Once the device is sorted out, the log file will telll you about the node IDs for your devices. That file is the openhab.log file that we discussed previously.