Another fun Weather Binding question for OH2

And i was doing soooo good! And the the weather binding kicks me in the gut…

Installed the 1.9 binding through paper ui.

i get this in the log:

Weather location setting ‘location…’ is missing its location. Check openhab.cfg.
Incomplete location config for locationId ‘’. Check openhab.cfg.

so i know there are two … there between location…home. i fixed that a long while back.
i do not have an openhab.cfg file. i have a weather.cfg file just like it needs.

location configuration, you can specify multiple locations

i have my apikey in the upper part of that file.

I tried uninstalling the binding and removing the weather.cfg and weather.items file, rebooting and then reinstalling. no joy. i get that same message.

just seems like its looking for something in the wrong place.



The naming of a location is a bit tricky, the “name” with which you can call all channels ( like temp visibility, etc) is the word after “location.”.
You don’t have to use “home” in here!
The label ( or the channel" name") is set using the “location.NameofYourLocation…name”.
Using different words for the name and label would help.

so your saying something like this?

location.point1. name=Myhome
location. point1.latitude=53

I had a very similar issue. There was a file in the cache folder that messed it up - you can try following this one: Weather Binding Disabling weather locationId

The following worked for me:

After you’ve done this, do a REBOOT (I forgot and then it didn’t work) - that solved a lot of problems with the binding and a missing for me, and should work on other references to weather.cfg.

Excellent, i am sure that is the answer but i get:

-bash: config:list: command not found

when i put in config:list

did some googling but not finding an answer. not a linux expert, duh…

i used the openhabian to install.


Ah, as far as I know you need to use the karaf console for this.

Then it should work. Also using log:tail in windows there would let you see
realtime errors and messages from the system…

Hope it helps!


Excellent! that did the trick. back in business! thanks for your help. would not have been able to figure that out and searching on the forum did not turn up that link. hopefully this will leave a trail for someone else!