App in Android Wear 2.0

Since upgrading my watch to Wear 2.0 (and thus getting the play store directly in the watch) I have got an item for openHAB in the category “Apps on mobile” in my watch’s play store, with a choice to install the app on the watch. However, clicking on install doesn’t seem to work, it just says “installing” forever. So there seems to be some kind of support for Wear but it’s not really working. Anyone got any input about how this is supposed to work? Would be nice with ability to control oh from my wrist :slight_smile:

Same problem here, would love a wear 2.0 version… Especially one that would not need a phone and directly uses wifi.

I’m also having the same issue with my Android Wear 2.0 watch.

I stumbled upon this issue as well.

Unfortunately same here. Install takes ages and then fails to install. Asus zenwatch 2 with wear 2.0

Any update on this? Have the same issue using my LG Watch Style with Wear 2.0.

Nope, haven’t heard a thing.

I just realized though that I never reported this anywhere but here. I’ve posted an issue about it on github now:

Seeing the outcome of that ticket, what direction should someone take to integrate Android Wear 2.0 to Openhab 2.x? I know there’s an AutoWear->AutoVoice->Tasker->Openhab solution chain described which I’m apprehensive to pay for until I’m confident there isn’t something else that can fill the need.

At least on the surface it seems I just need to get a voice command directed into the Openhab for Android App; from the watch.

SO i know this is a pretty old thread and most have probably given up on the idea but just to let you know i managed to get the openhab android app working on my watch (Ticwatch E running Wear OS). I uploaded a modified app here: and have opened a new ticket with the original repo. Its no way near a proper wear implementation but is nice for testing. Non wear apk’s can be installed on Wear OS using ADB. I might open a real Thread once i have run some more tests :slight_smile:



I test it on watch Huawei Watch. Is not working on Bluetooth connection. Only works on WiFi connection.


hmmm thats exacly what i tried to fix. Have you installed the one from my fork? I do still get it sometimes as well but a quick close and open results in the sitemap showing. check out the issue on the official repo (should have posted it in the original post)
I might do some more testing over the weekend, figure out why its not changing the network fast enough (or whatever the rason is).
Anyways thanks for the feedback, feels real good to see it can be useful for others too! (hope you didnt just join for my app :astonished:)

Hmmm… I interpreted the comment from your release as this would only work on wifi, so I haven’t really tested it yet. I have wifi inactivated on my watch (just seems like an energy thief and I always have my phone in my pocket anyway) so for this to be useful for me it needs to work over bt.

With that said, I’d just like to say I’m happy someone is working on this! Would be wonderful to be able to control OH directly from the wrist :sunny:

You are correct, it only works via wifi, because the bluetooth tethering is a whole different chapter and it did not work out of the box, so that will take some time (and maybe more know how than i have). The issue i fixed (tried to), is the network selection. Because when u have both enabled, the smartwatch will default to the energy conserving bluetooth connection instead of the wifi, so i added a “request” for wifi in the code. This way you should be able to leave both activated and it starts wifi transmission once the app starts.

I tried your APK on my Huawei watch 2 but with no luck. I have a white screen and then exits. Any suggestion?

Thats weird, have you installed it with adb? What wearos version are you using? It should work just like on a phone. Since i didnt develop the app, just modified some small stuff. I cant really help with debugging. Sry

I’m using wearos 2.3. Thanks a lot anyway.

I have the same problem with my Fossil Q with wearos 2.6

since i cant reproduce the issue i dont know how i can help. can you guys get anything else to work. does the app work on a normal smartphone? since the arduino base should be the same i can only guess a recent update broke sth. , which will be hard to debug since the app isnt developed to run on wearos in the first place :frowning:

1 Like

Ok! I have on my smartphone (OnePlus 6 with android pie) the last version of the openhab app and the last version of the openhab beta app (downloaded from this link Both app versions works well. I’ve installed on my smartwatch with wearos 2.6 the apk (downloaded from this link of the wearos openhab app through adb.
When I try to open the webapp on wear os the screen becomes white and then the app crash. I hope I was helpful.

have you tried using the latest openhab app on your phone as well? it will have connection issues but at least it should start, then we know its a issue with the old version. otherwise its an issue between the app and your watch witch as i said only the app devs will be able to fix. and since its not ment to be used with a watch i dont think they will spent any time on it.

1 Like