Append new item to group. Group does not update

groups
items
Tags: #<Tag:0x00007f51dc35b170> #<Tag:0x00007f51dc357ef8>

(Gerstl) #1

I just appended one item to two different allready existing groups.

The item does not show in the sitemap groups
Is this a correct behavior?

After a reboot it is working as it should.

What do I have to do to become the groups updated on a running system, without making a reboot?


Adding new item to an existing persisted group; won't persist
Restore z-wave state of items from presistence after items file is changed
(Ian Hubbertz) #2

I have the same issue. Even more strange: If an item was already member of another group, also this group membership is deleted from the Group, but not from the item itself.

I changed the item “heizung_1” that was already member of group “Heizung” to be member of an additional group:

00:27:29.499 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'heizung_1' received command ON
00:27:29.611 [INFO ] [marthome.event.ItemStateChangedEvent] - heizung_1 changed from OFF to ON
00:27:32.381 [INFO ] [marthome.event.ItemStateChangedEvent] - balkon_press changed from 1023.41 to 1023.46
00:27:32.402 [INFO ] [ome.event.GroupItemStateChangedEvent] - pressure changed from 1023.41 to 1023.46 through balkon_press
00:27:33.181 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'heizung_2' received command ON
00:27:33.319 [INFO ] [marthome.event.ItemStateChangedEvent] - heizung_2 changed from OFF to ON
00:27:33.326 [INFO ] [ome.event.GroupItemStateChangedEvent] - Heizung changed from OFF to UNDEF through heizung_2
00:27:33.359 [INFO ] [g.eclipse.smarthome.model.script.BOT] - Group 'Heizung' received updateHeizung (Type=GroupItem, Members=11, State=UNDEF, Label=null, Category=null)
00:27:35.734 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'heizung_2' received command OFF
00:27:35.876 [INFO ] [ome.event.GroupItemStateChangedEvent] - Heizung changed from UNDEF to OFF through heizung_2
00:27:35.883 [INFO ] [marthome.event.ItemStateChangedEvent] - heizung_2 changed from ON to OFF
00:27:35.917 [INFO ] [g.eclipse.smarthome.model.script.BOT] - Group 'Heizung' received updateHeizung (Type=GroupItem, Members=11, State=OFF, Label=null, Category=null)
00:27:36.650 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'heizung_1' received command OFF
00:27:36.784 [INFO ] [marthome.event.ItemStateChangedEvent] - heizung_1 changed from ON to OFF

Contents:

heizung_1 (Type=SwitchItem, State=OFF, Label=1: Zimmer OG, Category=null, Groups=[Heizung])
openhab> smarthome:> heizung_2
heizung_2 (Type=SwitchItem, State=OFF, Label=2: Schlafzimmer, Category=null, Groups=[Heizung, Schlafzimmer])
openhab> smarthome:> Heizung
Heizung (Type=GroupItem, Members=11, State=OFF, Label=null, Category=null)

According to the number of members (11) the Group ‘Heizung’ is complete - however, the group does NOT receive update if heizung_1 is updated - and the new group is not listed for the item heizung_1.


(WayneStronach) #3

Have the same issues - rather than reboot try restarting openhab2 - “sudo systemctl restart openhab2.service” or “sudo /etc/init.d/openhab2 restart”.


(Frank Reeth) #4

I have the same issue. Still no resolution? I can’t imagine someone can use openHAB without groups or restart openHAB after every change of group membership of items.


(Roel) #5

Same issue for me… changes in one of my *.items files are not reflected in Openhab untill i restart Openhab. Pretty annoying… and i haven’t found a solution yet.

Recreating the items file and its contents does not make a difference…


(Digitalvitamin) #6

+1
Same problem for me.
Perhaps it’s platform related? Running on a Synology here …


(Michael) #7

Same for me as well. I’m on RPI3. Restart of the openhab2 service mitigates the issue.
Is there a fix availiable?


(Lolodomo) #8

An issue should be opened in ESH repo: https://github.com/eclipse/smarthome


(Vegard Surlien) #9

Same for me, but was looking at friends new installed rpi3. No problems there. Groups was updated without restart.


(Konstantin Suvorov) #10

I was trying out groups in my setup this evening. Decided to group all lights into single switch group.
All items has been already defined in my config and worked well via bindings.

So I added

Group:Switch:OR(ON, OFF) Lights "Active Lights [%d]"

as per documentation.

Then added (Lights) to every bulb in question, like this:

Switch WB_MR6C2_Out2 "Output 2.2" (Lights) {modbus="slave5:1"}

And added Lights group to my sitemap.

And my new group was empty, no items was registered under the group. I was pulling my hairs for about two hours to find out what’s happening, searching forums and manuals. To no avail.

Then I added new dummy item to my config and added to Lights group. And it appeared under group listing!

Then I commented out all my existing items, saved my.items; uncommented them back, saved.
And my Lights group was then filled with all the items and worked as expected afterwards!

Not sure is it a bug or some glitch?..