Apple watch

Apple Watch app worked for me for some time but now it says Error Cancelled and then Retry. Retrying doesn’t help.

but watch site map is already there and always was. It worked for some time but then stopped…

I just changed my watch sitemap from UI generated to file based (watch.sitemap) and it is working again.
Please post your watch.sitemap, so we can check what’s going wrong…

My setup: OpenHAB 3.2.0.M4 and the latest version of the OpenHAB app from Testflight (2.4.37). I have sometimes an error message on my apple watch (timeout), but it disappears when I hit “retry” and eventually I can see my watch sitemap.

my site map is very simple, it has 3 switches only. It worked for some time in the past, then stopped working for several weeks (see my screenshot above). Yesterday I tried it again, it showed different error, something about ssl connection. I pressed Retry and it started to work again (but I didn’t change anythingin openhab).

Please activate “ignore ssl errors” in your openHAB iOS app, which should then sync to your watch…

1 Like

oh my god - it’s wonderful. What I have to do for have it? only “watch” file name as sitemap ?? sorry but I’m reading this post and I don’t undestrand… :thinking:
I’m using iphone12 update but and old apple watch with 4.3.2 software version… is this the problem?

I just found the answer on Apple store… the app require watchOS6.0 and newer… :sob: :sob: :sob:

Hi guys,

I’m also struggling with my Openhab on Apple Watch v7. If I’m on the local network, then the Openhab app is working correctly (the testflight version) on my watch, but once I’m on internet it is always showing a blank screen or a 401 error (Response status code was unacceptable: 401. [Retry]). The retry then does nothing, the same error occurs in cycle. I’ve already changed my cloud PW to eliminate all the special characters, but it did not help. Does anyone have any suggestion, what else I can try?

BTW: as a workaround I’m using the iOS shortcuts to trigger some OH actions, but unfortunately it cannot display information, it only triggers an action.

Any help is really appreciated.

I don’t like the sliders in the Android app, so I changed to Setpoint instead.

Really I only need 3 or 4 preset levels, so this works really well.

I have no idea if it works on the Apple watch, but I’d love to know.

Good luck

On the iPhone app try turning on Ignore SSL Certificates and Always Send Credentials

1 Like

Thanks. It works the same using a slider as it does with a setpoint. You just set the step= parameter. The controls just look different (I get a line with a position on the slider and - & + on each end versus 2 arrows with no position info for a setpoint).

Nope. That doesn’t help with the 401 issue when you’re not on the same LAN.

Hi Michael,

The ignore ssl certs is already turned on. The always send credentials does not help, but results more issues. When I enable it, the iPhone app is not able to connect locally, remotely the phone connects. On the watch, the error is different when I enable, it is Error Cancelled :slight_smile: .
So these settings does not help.

Do you have any other idea, what I can try?

I just want to share some positive news. I use OH3.2.0, iOS 15.2 / watchOS 8.3 / WatchApp V2.4.36.
I created a watch sitemap in the UI (did not work).
Then created a watch.sitemap file with the code of the UI and placed it in xxx/conf/sitemaps and deleted the UI sitemap (still does not work) - this was the code:
sitemap page_579094ff2c label=“watch” {
Text icon=“solarplant” label=“PV” item=PVPower
After renaming page_579094ff2c to watch - it worked:
sitemap watch label=“watch” {
Text icon=“solarplant” label=“PV” item=PVPower
Maybe this helps…
One little addition - when I add a “List” item in the sitemap I will get a error 404 - when changing back to “Text” - it is working.

1 Like

Hi Michael,

Does your sitemap work on your watch through internet as well? Mine work fine when I’m connected to the internal network, but not through internet. I have a feeling, that the authentication to is having a problem.

I have a very simple sitemap, with only basic elements:

sitemap watch label=“watch” {
Switch item=Switch_GarageLight2_OnOff label=“Garage ext. lights” icon=“light”
Switch item=Switch_ExtLamp_OnOff label=“House ext. lights”
Switch item=Switch_LampsIndoorAll label=“House lights (all indoor)”
Text item=SWeather_LivingRoom_temperature label=“Inside [%.1f °C]” icon=“temperature”
Text item=SWeather_Outdoor_temperature label=“Outside [%.1f °C]” icon=“temperature”

@abal Hi Attila,
unfortunately it is only working in the internal network. Not over the internet, same like you.
Do you know how we can raise a incident or bug to the dev team?
Yours Michael

I think it is already there:

There is a pull request ongoing, which has also some changes on the authentication. I’ve tried this version through TestFlight, but it was still not working, however I was not able to find out whether that TestFlight version was really including the changes.
I left a question on the PR discussion, let’s hope someone will check it.

Here is the mentioned PR:

@abal - I also left a comment - would be great if they oick it up. Its the last missing pice in may openHAB environment that is not working.