Argghh. Stopped working

So, what’s happened recently to OH2? I have been happily running this for weeks, all of a sudden I am receiving errors in the logs file when trying to turn on lights. I get “Invalid payload sent…” using my MQTT client. I have not changed a thing. It’s just ceased working.

mqtt.things

Bridge mqtt:broker:b_MQTT_broker "MQTT Broker for engMQTTclient" @ "Energenie"

[

    host="localhost",

    //port=1883,

    secure="false"

    //username="",

    //password=""

]

sockets.things

// SOCKETS

//Energenie ENER002 #1

Thing mqtt:topic:b_MQTT_broker:t_Socket_1 "Socket Dad" (mqtt:broker:b_MQTT_broker) @ "Lounge" {

     Channels:

        // Socket - table lamp

        Type switch : c_Binary_Switch_1 "Switch" [commandTopic="/energenie/ENER002/444102/1"]

 }

//Energenie ENER002 #2

Thing mqtt:topic:b_MQTT_broker:t_Socket_2  "Socket Lounge" (mqtt:broker:b_MQTT_broker) @ "Dad" {

     Channels:

        // Socket - table lamp

        Type switch : c_Binary_Switch_2 "Switch" [commandTopic="/energenie/ENER002/444102/2"]

}

lights.items

Group:Switch:OR(ON,OFF) g_Lights

//Group g_Lights

// Control lighting mode

Switch i_Lights_Mode "Lighting"  

/* Lounge */

Switch i_Light_Lounge_Tablelamp "Lounge window tablelamp" <light> (g_Lights) {channel="mqtt:topic:b_MQTT_broker:t_Socket_1:c_Binary_Switch_1"} 

/* Dad */

Switch i_Light_Dad_Tablelamp "Dad tablelamp" <light> (g_Lights) {channel="mqtt:topic:b_MQTT_broker:t_Socket_2:c_Binary_Switch_2"}

openhab.log

Feb 25 23:46:41 openhab sh[6072]: [stderr] 20200225 23:46:41.510 ERROR    MQTTClient- Invalid Payload for ENER002
Feb 25 23:46:41 openhab sh[6072]: [stderr] 20200225 23:46:41.033 ERROR    MQTTClient- Invalid Payload for ENER002
Feb 25 23:46:36 openhab sh[6072]: [stderr] 20200225 23:46:36.005 ERROR    MQTTClient- Invalid Payload for ENER002

events.log

==> /var/log/openhab2/events.log <==
2020-02-25 23:46:35.969 [ome.event.ItemCommandEvent] - Item 'i_Light_Lounge_Tablelamp' received command ON
2020-02-25 23:46:35.984 [nt.ItemStatePredictedEvent] - i_Light_Lounge_Tablelamp predicted to become ON
2020-02-25 23:46:35.997 [vent.ItemStateChangedEvent] - i_Light_Lounge_Tablelamp changed from OFF to ON
2020-02-25 23:46:40.975 [ome.event.ItemCommandEvent] - Item 'i_Light_Dad_Tablelamp' received command OFF
2020-02-25 23:46:41.005 [nt.ItemStatePredictedEvent] - i_Light_Dad_Tablelamp predicted to become OFF
2020-02-25 23:46:41.030 [vent.ItemStateChangedEvent] - i_Light_Dad_Tablelamp changed from ON to OFF
2020-02-25 23:46:41.479 [ome.event.ItemCommandEvent] - Item 'i_Light_Dad_Tablelamp' received command ON
2020-02-25 23:46:41.491 [nt.ItemStatePredictedEvent] - i_Light_Dad_Tablelamp predicted to become ON
2020-02-25 23:46:41.507 [vent.ItemStateChangedEvent] - i_Light_Dad_Tablelamp changed from OFF to ON
2020

I swear, this has been running fine unmodified for days. Today it stopped. I also had problems connecting via cloudHAB , that was a pain too.

Ive been trying out HomeAssistant and its much easier to manage in terms of it “just works” but, it is not as flexible or comprehensible as OH, particularly I love OH files and the rules syntax. Please help me stay with OH.

I have TRVs that use the same b_MQTT_broker and these work, so I know the MQTT broker is fine :-

trv.things

Thing mqtt:topic:b_MQTT_broker:t_TRV_Lounge  "Lounge TRV" (mqtt:broker:b_MQTT_broker)   @ "Lounge" 
 {
     Channels:
        /* Current temp , is published periodically by the TRV */
        Type string : c_Temperature_Lounge        "Temperature" 		[stateTopic="/energenie/eTRV/Report/Temperature/8008" ]
        /* In the following channels , states can only be obtained AFTER the corresponding commandTopics are triggered (with NIL payload) */
        Type string : c_Target_Temp_Lounge        "Target temperatue" 	[stateTopic="/energenie/eTRV/Report/TargetTemperature/8008"]
        Type string : c_Set_Temperature_Lounge	"Set temperature" 	[commandTopic="/energenie/eTRV/Command/Temperature/8008" ]
        Type string : c_Diagnostics_Lounge        "Diagnostics"		[stateTopic="/energenie/eTRV/Report/Diagnostics/8008"]
        Type string : c_Voltage_Lounge            "Voltage"		[stateTopic="/energenie/eTRV/Report/Voltage/8008"]
        Type string : c_Identify_Lounge           "Identify"		[commandTopic="/energenie/eTRV/Command/Identify/8008" ]
        Type string : c_Exercise_Lounge           "Excercise"		[commandTopic="/energenie/eTRV/Command/Exercise/8008" ]
        Type string : c_Valve_State_Lounge        "Valve state" 	[commandTopic="/energenie/eTRV/Command/ValveState/8008" ]
        Type string : c_Power_Mode_Lounge         "Power mode"		[commandTopic="/energenie/eTRV/Command/PowerMode/8008" ]
        Type string : c_Reporting_Rate_Lounge     "Reporting rate"	[commandTopic="/energenie/eTRV/Command/ReportingInterval/8008" ]
        Type string : c_Refresh_Voltage_Lounge     "Refresh Voltage"	[commandTopic="/energenie/eTRV/Command/Voltage/8008" ]
        Type string : c_Refresh_Diagnostics_Lounge "Refresh Diagnostics"	[commandTopic="/energenie/eTRV/Command/Diagnostics/8008" ]
 }
  

and that works fine.

I have not changed any .things or .items. Why oh why has it stopped working??

You need to pull a debug log and review it.

Stop OH, clean the cache then restart OH two (make sure to allow OH to fully reload) more times. If this does not work check your system OH is running on.

1 Like

Sounds more like an MQTT topic coming in from the remote device/service that you weren’t expecting

1 Like

It is not a topic problem - nothing has changed. Other topics are working fine. I have not changed any topics. In fact, I have not changed my config for weeks.

I have restarted OH , rebooted and restarted, cleaned cache and restarted. Still same.

I tried to use PaperUI instead of files.
So, I created an MQTT broker “myBroker” from the MQTT Binding. Broker comes online and confirmed in the logs.
I then created a Generic MQTT Thing which is using “myBroker” . I used the identical settings used by working TRV generic things. I save, it comes online, logs confirm, and when I click on the thing again, the broker settings have gone. This is a problem . It never used to do this. I keep losing the broker name, the thing in PaperUI states:-

You need a configured Broker first. Dynamically add channels of various types to this Thing. Link different MQTT topics to each channel

If I set the broker to myBroker or indeed any broker, it looses that setting.
I have deleted all .things files then went into PaperUI. They are still there. So I tried to delete them and I get “Error: 409 Conflict”
Dont know how to fix this. Looks a mess.
This is confusing. I am on OH2.5.2-1 and have been for some time.

I would suggest to first check the incoming payload with an external mqtt tool.

no no no … its not that. Hasnt changed since I installed . please read above. NOT CHANGED

Is there a guru who can help diagnose.
Im also getting errors in openhabian-config when installing latest version. At the end of the install , I click OK then it says "50 ! Error or interrupted " ??
Getting silly now

Well, not now. Apparently, you’ve deleted everything but still have stuff left. Shall we start with that? Have you restarted since deleting all your Things files? many bindings are not so good at handling removals in-flight.

No no no @rossko57 - the problem started when I upgraded OH.

NOTHING OF MY CONFIG CHANGED

how clear does it have to be

look, Ive had a hard time on this forum and OH has been problematic. There’s a cultural attitude on here that is distasteful. There’s too many “well , USA is the greatest place on earth and I’m the greatest USA citizen”. Too many big heads and too little humilty and humbleness.

I tried Home Assistant for the first time today:-

  • Installed Raspbian Lite and performed a custom install using python3 venv.
  • Worked FIRST TIME for all bar Z-wave.
  • TENS of greetings, people PMing me, multiple answers to questions, all helpful.
  • Ended up that I had to activate serial line and SPI in Pi config to get Z-wave working.
  • All devices discovered
  • No files, No PaperUI
  • Excellent class leading interface
  • Superb Phone “card” widgets
  • Doddle to configure
  • Loads and Loads of UPTODATE docs
  • No attitude

So long folks

Okay, trouble reconciling all this.

Well, first of all - It´s very far from beeing clear, when you start of with AND continue to say, you havn´t changed anything.
And NOW, several post after, you tell us, this problem started when you upgraded OH :open_mouth:
If upgrading OH is equal to “not changing anything” for you, how th hell do you suspect us to be able to help you?..

I wish you all the best of luck with HA…You surely gona need it with that opinion!