Astro 1.9 Binding Missing?

I just did a complete purge of my existing OH2 install and reinstall of the latest Beta via apt-get. And after enabling 1.x Binding support, I see the Astro 1.9 binding is missing?

Do we still need the 1.9 binding to trigger events?

The latest build includes the OH2 Astro binding that supports events. I’m just starting to look at it now.


I just copied over my OH1 Astro items file. Hopefully the rules fire later at sunset as I’m about to run out and can’t do much testing.

Early Merry Christmas to everyone as well.

I migrated from astro1 to astro2 today, looks like everything is working fine.
Note that the most current docs are here ( is not updated yet):

Events do work now, but they are triggered differently:

rule "example trigger rule"
    Channel 'astro:sun:home:rise#event' triggered START 

Delayed events are not supported, but I made it working using the new expire binding:


Switch Dawn15mDelay_Proxy "Dawn 15m delay" {expire="15m,command=ON"}


rule "civil Dawn delay"
    Channel 'astro:sun:home:civilDawn#event' triggered START  
    Dawn15mDelay_Proxy.sendCommand(OFF) //delays dawn event for xx minutes

then trigger on Dawn15mDelay_Proxy which state will be ON after -in this case- 15 minutes.
Maybe there is a better way but this one was the easiest for me.

If you are using transformation mapping, the events are coming in now upper case, you need to change in your .map file f.e.
Autumn=Herbst to AUTUMN=Herbst


Thanks for the heads up!
While it is nice that Astro 2 is moving on, I guess I need to stay with my one week old OH2 if I want to trigger e.g. 30 minutes prior dawn/set, which is easly done with Astro 1. (?)

Is it confirmed that Astro 1 is no longer around in the latest nightly?

I still can see it in #673:

That’s a releif!


I was having the same problem, the UI is kind confusing. Using the Paper UI, you need to go to Configuration->System and enable both Access Remote Repositories and Include Legacy 1.x Bindings.

Thats was very strange as I know I had done that and it is the first thing I do with every fresh install. Perhaps the settings didnt take when saving, but in doing it a second time I see the 1.9 binding.

And earlier I had seen other 1.x bindings but not the astro one. All strange but its there now in the extensions.

This needs to be updated:
Events and offsets are possible now with the astro2 binding:

Just wanted to circle back on this that I wasn’t going crazy. I just did a new fresh install of OH2. On the first startup, I chose ‘Expert’. Then when I went to Habmin, the Astro 1.9.x binding does not show up.

It appears that if you set things to ‘Expert’ when first starting it lists/shows most of the 1.9 bindings although in PaperUI the Legacy Bindings was not enabled.

After actually enabling the Legacy Bindings in PaperUI did the Astro binding then show back up in Habmin.