[Astro Binding]: Queue full

Tags: #<Tag:0x00007fc8f3701930> #<Tag:0x00007fc8f3701840> #<Tag:0x00007fc8f3701778>

Right, the astro binding was moved from OH2 to ESH recently, so the version makes sense.

Nevertheless, the “Queue full” sounds puzzling. I saw that with some initial versions, but not (yet) with the fixes that made it into the b5 build.

@spy0r would you please create an issue in https://github.com/eclipse/smarthome with the stacktrace? We then can track it there.

Any help on finding out what needs to be done in order to reproduce it is appreciated, of course!

i will, if you tell me what a stacktrace is :smiley:

Ah, sorry :rofl:! I just meant the excerpt from the logfile that you already pasted here in your initial post.

The gibberish with all the lines starting with “at” is what in Java is called a stacktrace - it tells us which places in the code it ran through when the error happened.

Thanks for your help!

Hi,
I am experiencing the same error now and triggers are not firing cause of it.
Has this been fixed in the OH2.1 stable version? How do I update?

No, i reported these errors in the 2.1 stable release. (Sorry for not noting it).

Log into the karaf konsole and restart the astro binding, that will solve it for some days, or weeks?

Same error here on OH 2.1 stable release. For what it’s worth, I’ve upgraded from 2.0 to 2.1.

For those of you unfamiliar with the commands, you can restart the bundle by first “START ID” number using the bundle:list command. Then, use that number to stop and start the astro bundle using the bundle:stop and bundle:start commands, respectively.

Maybe a dumb question, but is it still possible in OH2 (as it was with OH1) to just to exchange the JAR file of the astro binding to update this particular binding to the most recent one, without upgrading the entire OH2.1 system to an unstable release?

@Zaphood1967

Yes, you can do that, but… The last ESH stable release was June 26, which does not include the astro binding fix (the astro binding recently was moved from the OH2 addons code base to the ESH code base). Therefore, I don’t think the fix for this bug will be available in a snapshot (unstable) OH2 build until @Kai builds the next ESH stable release.

Sorry again for my lack of knowledge, but what does ESH stand for please?
Does this mean, that there is no chance to have a workaround to update the Astrobinding to a working version until Kai releases this ESH? (I am guessing ESH is the stable release ?)

http://docs.openhab.org/introduction.html

Eclipse Smarthome

This happens every couple of days, for history see:

https://hudson.eclipse.org/smarthome/job/SmartHomeDistribution-Stable/changes

Cool, thanks a lot. Kind of obvious but wasn’t stil that clear to me :slight_smile: Too many acronyms in IT…

So again for my understanding: For the time being it is not possible to replace the jar until Kai has released a STABLE ESH version? In other words, before the STABLE release of 2.2 there is no chance to have a fixed astrobinding.jar?

Thanks again

If you want to stay on stable releases, you are right, you will have to wait for openHAB 2.2 stable.

You still can use snapshot bindings in openHAB2 (uninstall the binding via PaperUI, put the snapshot binding in your addons folder, restart openHAB).

I don’t know if that is also possible with the astro binding, because it is part of ESH.

Thanks for clarification !

FTR: Major ESH upgrade in 2.2.0-SNAPSHOT
So in the latest 2.2.0-SNAPSHOT, the astro binding works smoothly!

I updated the astro binding. Let’s see :slight_smile:

So when can we expect 2.2 stable then, please?

Is there someplace I can grab just the astro binding’s JAR from SNAPSHOT and use that for now?

I’m not brave enough to move to SNAPSHOT, but I am using astro and this bug is hitting me.

I’m also not Java savvy, so building from source isn’t an option for me.

Thanks for any help!

I haven’t tried this, so use caution :exclamation:

Download zip from https://hudson.eclipse.org/smarthome/job/SmartHomeDistribution-Stable/

extract zip, find org.eclipse.smarthome.binding.astro_0.9.0.xyz.jar
install manually (don’t forget to uninstall the existing astro binding first)

Maybe it won’t work since there are additional changes in the ESH distro in other jars also.

Moving to snapshot is really not something to worry about. It is as stable as the release build.
You can always revert back to 2.1 stable from snapshot if you don’t like 2.2 snap :slight_smile:

1 Like

Okay, I uninstalled the astro binding, then dropped the jar into the addons folder, then restarted OpenHAB.

The astro binding started up with no errors, and rules are working, so we’ll see what happens in a few days.

Thanks for your help!

1 Like