[Astro Binding]: Queue full

Thanks for clarification !

FTR: Major ESH upgrade in 2.2.0-SNAPSHOT
So in the latest 2.2.0-SNAPSHOT, the astro binding works smoothly!

I updated the astro binding. Let’s see :slight_smile:

So when can we expect 2.2 stable then, please?

Is there someplace I can grab just the astro binding’s JAR from SNAPSHOT and use that for now?

I’m not brave enough to move to SNAPSHOT, but I am using astro and this bug is hitting me.

I’m also not Java savvy, so building from source isn’t an option for me.

Thanks for any help!

I haven’t tried this, so use caution :exclamation:

Download zip from https://hudson.eclipse.org/smarthome/job/SmartHomeDistribution-Stable/

extract zip, find org.eclipse.smarthome.binding.astro_0.9.0.xyz.jar
install manually (don’t forget to uninstall the existing astro binding first)

Maybe it won’t work since there are additional changes in the ESH distro in other jars also.

Moving to snapshot is really not something to worry about. It is as stable as the release build.
You can always revert back to 2.1 stable from snapshot if you don’t like 2.2 snap :slight_smile:

1 Like

Okay, I uninstalled the astro binding, then dropped the jar into the addons folder, then restarted OpenHAB.

The astro binding started up with no errors, and rules are working, so we’ll see what happens in a few days.

Thanks for your help!

1 Like

Where did you download the JAR file, please? As I thought I had understood, Astro Binding is part of the core system and cannot be downloaded separately?
Happy to see that I might have been wrong :slight_smile:

1 Like

What Dim said worked for me, download the zip, and extract the jar from it manually.

I have not had any issues since I did this so it is a workaround.

Following @Dim’s suggestion to install the 0.9.0 astro binding seems to have resolved this issue for me as well.

I thought I would add a bit more detail here.

Trouble description:
After perhaps two weeks of normal operation, my astro-based rules stopped working. A reboot of the system would fix the problem, but the issue would re-appear after about two weeks.

Astro events stopped appearing in the event log, and the ‘Queue full’ message appeared in the log file as noted by @spy0r, above.

System description:
I am running openHAB 2.1 on a raspberrypi using rasbpian jessie. I had installed the astro binding through the paperUI.


  • Uninstall the astro binding using the paperUI. DO NOT delete any of your astro items or make any other changes.
  • Download the latest snapshot version, and unzip the file into a convenient directory
  • Look in the ‘plugins’ directory of the snapshot for astro-related .jar files. In my case, the file name was
  • Copy this file to /usr/share/openhab2/addons (note that this is for a Debian-like distribution)
  • Reboot

Once this is done, login to the Karaf console

ssh -p 8101 openhab@localhost <- password is habopen

Issue the command

bundle:list |grep Astro

You should see a line indicating that the Astro binding is active.

N.B. The paperUI does NOT show that the binding is installed, but of course, it is.

1 Like

For all who like to stay on the stable release:
After observing the logs within my graylog instance it seems that the faulty astro binding works for one week until “Queue full” strikes again.
Until 2.2 is stable I schedule an openHAB restart each sunday …


Just want to put a +1 here. I did not observe the frequency but about two weeks seems correct.

i did check with the 0.9b but this does not help at all

openhab> bundle:list |grep Astro   
181 | Active    |  80 | 0.9.0.b5               | Astro Binding

017-09-03 00:00:00.028 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:moon:local
2017-09-03 00:00:00.063 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:sun:local
2017-09-03 00:00:00.071 [INFO ] [Manager$ExpressionThreadPoolExecutor] - Expression '0 0 0 3 9 ? 2017' has no future executions anymore
2017-09-03 00:00:00.076 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:moon:home
2017-09-03 00:00:00.075 [ERROR] [thome.binding.astro.internal.job.Job] - Queue full
java.lang.IllegalStateException: Queue full
	at java.util.AbstractQueue.add(AbstractQueue.java:98)[:1.8.0_144]
	at org.eclipse.smarthome.binding.astro.handler.AstroThingHandler.addJobToQueue(AstroThingHandler.java:314)[181:org.eclipse.smarthome.binding.astro:0.9.0.b5]
	at org.eclipse.smarthome.binding.astro.internal.job.Job.schedule(Job.java:58)[181:org.eclipse.smarthome.binding.astro:0.9.0.b5]
	at org.eclipse.smarthome.binding.astro.internal.job.Job.scheduleEvent(Job.java:94)[181:org.eclipse.smarthome.binding.astro:0.9.0.b5]
	at org.eclipse.smarthome.binding.astro.internal.job.Job.scheduleRange(Job.java:115)[181:org.eclipse.smarthome.binding.astro:0.9.0.b5]
	at org.eclipse.smarthome.binding.astro.internal.job.DailyJobSun.run(DailyJobSun.java:66)[181:org.eclipse.smarthome.binding.astro:0.9.0.b5]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_144]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_144]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)[:1.8.0_144]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)[:1.8.0_144]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)[:1.8.0_144]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)[:1.8.0_144]
	at java.lang.Thread.run(Thread.java:748)[:1.8.0_144]

And from here it shuts down Openhab really complete - nothing works any more…

Is this still the solution if I am already running Astro Binding version 0.9.0.b5 ? I am running this on an openhab 2.1 and I am getting the queue error on a regular basis. Just wanted to make sure before I do all of this: deinstalling + reinstalling the binding from the current (openhab) snapshot fixes that?

Did you try it? I have the problem with “XXXXXX has no future executions anymore”. Also running on the release build…

Thank you in advance.

Edit: Not working for me - lots of errors with the Astro Binding “” :confused:

1 Like

Same for me with org.eclipse.smarthome.binding.astro_0.9.0.201711242229.jar . More recent builds do not seem to work with 2.1 and older ones are not available any more on https://hudson.eclipse.org/smarthome/.
@bgilmer @kmeurer you happen to have your org.eclipse.smarthome.binding.astro_0.9.0.201708281632.jar (or the like) still somewhere lying around? Would appreciate a share, thanks a lot!

@GreenDaddy, I have that file. If you send me a PM, I will send you a share link.

1 Like

Thanks, Brad! It seems that I cannot send a PM, maybe because I am a new user. :frowning: I have an Inbox, however.
Can you please send me the link as PM anyway @bgilmer ? Much appreciated!


Try downloading the file from this link. Please let me know as soon as you have downloaded it so I can delete the file.

[https://drive.google.com/file/d/1fdJGGBSWRbWH4_BnpQ1GhWPjIPUX-EsV/view?usp=sharing](http://Google Drive - org.eclipse.smarthome.binding.astro)

1 Like

Thanks! The 20170828 worked like a charm!

Not even had to reboot - just uninstalled the old one using paperui and copied the new one in:

2017-12-20 16:39:37.005 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI
2017-12-20 16:39:44.377 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2017-12-20 16:39:44.730 [INFO ] [ulation.internal.HueEmulationServlet] - Started Hue Emulation service at /api
2017-12-20 16:39:44.812 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-astro'
2017-12-20 16:44:16.963 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:sun:local
2017-12-20 16:44:17.057 [INFO ] [ding.astro.handler.AstroThingHandler] - Scheduled Positional job astro:sun:local every 300 seconds
2017-12-20 16:44:17.377 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:moon:local
2017-12-20 16:44:17.415 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:sun:local
2017-12-20 16:44:17.419 [INFO ] [ding.astro.handler.AstroThingHandler] - Scheduled Positional job astro:moon:local every 300 seconds
2017-12-20 16:44:17.510 [INFO ] [ding.astro.handler.AstroThingHandler] - Scheduled Positional job astro:sun:local every 300 seconds
2017-12-20 16:44:17.854 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:moon:local
2017-12-20 16:44:17.866 [INFO ] [ding.astro.handler.AstroThingHandler] - Scheduled Positional job astro:moon:local every 300 seconds

Now waiting if it’s stable, but based on previous comments, it should be :slight_smile: