Astro don't trigger event at the correct time

Hi all, my rule does not trigger at the right time (it activates with 2 hours delay).
Clock and timezone are correct in:

  • PaperUi settings
  • Openhab log
  • Raspberry pi4 system clock (where OH is running)

Astro sunset time is correct. Rule is:

rule "Sunset"
    Channel "astro:sun:home:set#start" triggered START

What is wrong with this configuration?

It should be:
Channel ‘astro:sun:home:set#event’ triggered START
Channel “astro:sun:home:set#start” triggered START

Sounds like you should check your base operating system timezone setting

I will try

@rossko57 Base operating system timezone setting is already correct

What’s in your events.log? You should be able to find both the astro event and your rule-issued command

Problem solved, thank you anyway.