August Smart Lock Pro Unlocking Issue

Hi all,

I recently attempted to use an August 4th gen wifi lock with homekit, which didn’t turn out so well due to the bluetooth pairing with Apple TV being super slow.

I then purchased an August 3rd gen lock with Z-wave to go with my current z-wave setup (HUSBZB-1 and zooz switches) which has been working great with homekit, besides one issue.

On unlock command, the lock will go to unlocked status, back to locked status, and finally settling on locked status. It doesn’t do this when locking, only when unlocking. This is somewhat annoying because homekit sends a notification that the lock is locked when it should be unlocking.

I’ve tried setting various polling values; 1500, 3000, 6000; but none seem to keep it from trying to assess its status right after unlocking. I’ve also removed/repaired/reset the lock, but the issue persists. I’ve set z-wave logging to debug, but I’m not sure what I should paste here, since the logging is a mile long during this action.

Have you tried disabling the Command Polling? Most devices will report their own states, so the Command Polling is not needed, but the default is set to 1500ms.

Yes, I should have said that as well; disabling actually makes it worse because it does it during unlock too.

The longer the delay, the longer it will wait before “assessing the status”. If you make this 10 seconds for example, it will check 10 seconds after the command - not immediately. The maximum time is 15 seconds, and if this doesn’t change the sampling time I would be quite surprised.

Please just provide the log file. Don’t paste it - just provide a link to the file hosted somewhere.

Hi Chris,

I was under that impression as well, but that doesn’t seem to help; it still tries to do this lock/unlock/lock within a second or two of the command. I restarted openhab so I could start a cleaner logfile for you and now it won’t lock via homekit/openhab, only the August app :laughing:

Here you are, thanks for looking into it:

This could happen if everything gets delayed by (say) 10 seconds since the delay is kicked off from the time of the command. If the initial command is delayed, then the request will still have a fixed time.

Looking at the log, we can see this is working ok -:

This shows a 6 second delay between the command and the get request.

Same here - it’s just over 6 seconds -:

Here it’s about 9 seconds -:

I think that the delay is fine - although I’m not sure exactly what you set this to, it’s clear that it’s not “within a second or two”.

Does this show how it’s bouncing between lock/unlock? You can see the status update going to ON then back OFF after the command is received (slight overlap in the screenshots)

I’m not really sure what the lock is doing and it’s hard for me to comment on what is should do to be honest. It does change back to locked, but maybe that’s normal? Do you have autolocking enabled?

Wow, good call. Autolocking was inducing the issue. Now it operates correctly, both lock and unlock in homekit and openhab, even with polling disabled! Thanks for the help Chris.