Autelis Configuration for OpenHAB2

I am currently running openHAB2 and recently added an Autelis Controller to my installation. I installed the Autelis binding using the Paper UI Add-ons->Bindings->Autelis Binding. I added the following configuration statement to the mySite.things file:

Thing autelis:myPool [ host=“”, port=“80”, user=“admin”, password=“admin”]

This is directly from:

I believe there is something wrong with this configuration statement as all of my other ‘thing’ cease to work.

THe openhab.log file shows:
2017-03-13 13:44:10.694 [ERROR] [el.item.internal.GenericItemProvider] - Binding configuration of type ‘channel’ of item ‘PoolVersion’ could not be parsed correctly.
org.eclipse.smarthome.model.item.BindingConfigParseException: UID must have at least 4 segments.
at org.eclipse.smarthome.model.thing.internal.GenericItemChannelLinkProvider.createItemChannelLink(
at org.eclipse.smarthome.model.thing.internal.GenericItemChannelLinkProvider.processBindingConfiguration(
at org.eclipse.smarthome.model.item.internal.GenericItemProvider.internalDispatchBindings(
at org.eclipse.smarthome.model.item.internal.GenericItemProvider.dispatchBindingsPerType(…

If I remove the configuration statement from the .things file everything works as before and I don’t get the above log entry.

Any assistance would be appreciated.

The standard format for a Thing is to have three elements in that first part of the Thing:

Thing <binding id>:<thing type id>:<thing id>

It appears the thing type id is missing. So there appears to be an error in the readme for this binding. Unfortunately, I cannot begin to guess what the correct way to represent it would be. I would try the following:

Thing autelis::myPool

Thing autelis:autelis:myPool

If those don’t work I’d try to contact the author of the binding.

At a minimum I would file an Issue on the openhab2-addons github to correct the readme.

Thanks. I tried many different things but not the one that worked.

Thing autelis:autelis:myPool solved the problem.

Thanks. The Thing autelis:autelis:myPool solved the problem

Please file an Issue with this recommended update. Glad you got it working!

Where do I file an issue (URL)?

Actually changing the .things file to:

autelis:autelis:myPool [ host=“”, port=“80”, user=“admin”, password=“admin”]

only caused the error message in the openhab.log file to be resolved. It still was not initializing. Changing the .things file to:

autelis:poolcontrol:myPool [ host=“”, port=“80”, user=“admin”, password=“admin”]

to initialize however with a new warning in the openhab.log file stating the “port” could not be set. Changing the .things file to:

autelis:poolcontrol:myPool [ host=“”, user=“admin”, password=“admin”]

resolved the issues and the autelis controller initialized properly and went online. I have verified the proper data is being transmitted to openhab (via a sniffer), but there is still an issue in displaying the data. When I resolve that problem I will post the issue.

Yes I have verified that the binding is sending the ‘get status’ command to the autelis box and the box is returning the correct xml data. I can see this with the sniffer and also verified iit by sending the command manually. I believe the problem is in the items statement. The item statement I am using is:

String poolVersion “Version [%s]” {channel=“autelis:poolcontrol:myPool:system-version”}

The xml snippet which the autelis returns after the command is:

…0 … 1.0.0……

This means the binding must parse the xml using the ‘-’ as a delimiter. I have tried several different delimiters unsuccessfully. My next step is to check the binding source or email the author.

Sorry the xml did not come through. I will try again.

My third attempt


  • means undefined when it appears on the sitemap.

As my link above recommends, did you look in events.log to see if oh is parsing the values? Did you look in openhab.log for errors?

Yes I examined both the openhab.log and the events.log. The openhab.log showed the autelis controller being initialized and brought online with no errors. Also, the openhab.log showed a parsing error if I replaced the ‘-’ in the item statement with anything but the ‘-’. So oh appears to be parsing the input from the autelis controller, but no data is being displayed. The events.log shows nothing for the autelis interactions at all.

Hi, apologies, I think the docs are not correct. While I use config files to define my items, i let OH2 do autodiscovery to find my pool and configure through the paper ui, which is why this was probably not caught earlier. The correct format should be autelis:poolcontrol:myPool . Also what type of pool system are you connecting to?

I first tried the paper ui to configure the autelis controller, but autodiscovery did not find it. That is why I was doing the manual configuration. I discovered the correct format of autelis:poolcontrol:myPool by trial and error. I think I am getting it initialized properly now, but I am not getting any data displayed using:

String poolVersion “Version [%s]” {channel=“autelis:poolcontrol:myPool:system-version”}

Is this the correct syntax?

I am simply connecting a Pentair Intelliflow pump.

To correct my earlier post the following is the contents of the openhab.log:

11:48:42.000 [INFO ] [smarthome.event.ThingAddedEvent ] - Thing ‘autelis:poolcontrol:myPool’ has been added.
11:48:42.011 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘autelis:poolcontrol:myPool’ changed from INITIALIZING to ONLINE
11:48:42.011 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘autelis:poolcontrol:myPool’ changed from ONLINE to OFFLINE (CONFIGURATION_ERROR)
11:48:42.012 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘autelis:poolcontrol:myPool’ changed from UNINITIALIZED to INITIALIZING
11:48:42.375 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘autelis:poolcontrol:myPool’ changed from OFFLINE (CONFIGURATION_ERROR) to OFFLINE (COMMUNICATION_ERROR)

The configuration statement that I put in the .things file is:

autelis:poolcontrol:myPool [ host=“”, user=“admin”, password=“admin”]

I apparently didn’t look far enough in the log to see that a CONFIGURATION_ERROR and then a COMMUNICATIONS_ERROR were reported

Sorry for not putting this all in one post, but I think there is a second error in the configuration documentation:

Thing autelis:myPool [ host=“”, port=“80”, user=“admin”, password=“admin”]

should actuall be:
Thing autelis:myPool [ host=“”, port=80, user=“admin”, password=“admin”]

Otherwise you get an error indicating attempt to write a string into an integer.

Thanks @Larry_Pyle , so is it working for you now? I’m glad we have some other users of this binding, I will update the docs. I’m surprised auto discovery did not work, is your autelis on a different network?

Also to see what channels are available take a look at the thing in the paperui, each channel has a copy icon to copy the channel name to your clipboard.