Auto Discovery not working

  • Platform information:
    • Hardware: Rasberry Pi 3, Docker, Ubuntu VM
    • OS: Various (with same result)
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: Latest Stable, and Daily build
  • Issue of the topic:

OK , so I have tried various home automation platforms, none of which are auto-discovering my devices. Started off Docker on my synology and OpenHab, This didnt work, then Installed Ubuntu in a VM this didnt work, I purchased a Rasb Pie 3 and even resorted to the Hasbian image, attached it to wifi and for the life of me cannot auto discover anything.

What I am trying to discover:
30 TP-Link Devices
August Locks.

Platforms like Yonomi all discover devices without issue on the iphone.
What am I missing?

Spent several days researching, not finding anyone with this issue. Everyone states that the auto discovery works.

Could you please tell us, what Java version you tried.

What comes with Hasbian:

openjdk version “1.8.0_202”
OpenJDK Runtime Environment (Zulu8.36.0.152-CA-linux_aarch32hf) (build 1.8.0_202-b152)
OpenJDK Client VM (Zulu8.36.0.152-CA-linux_aarch32hf) (build 25.202-b152, mixed mode, Evaluation)

What bindings have you installed in order to discover them? And how are you discovering?

Cant find anything for August.
Clicking on the Inbox, Blue Plus, Clicking TP-Link Smart Home Binding.

Sorry seems like a trivial question.

Unfortunately I don’t have these devices… my only thought is that possibly the server cannot see the tp-link devices… not sure if they are pingable to check? have you tried manually configuring one of the tp-link devices using a thing file?

Great question, I have also thought this but then why other systems able to discover.
Also another clue I can add the things manually and they show up…

Seems like I have to do everything via textual configuration (which seems annoying).

Should also say everything is on Static DHCP Configurations.
All on the Same LAN.

Your question was the reason I decided to install on a Raspberry Pi 3 so that i can have it connect to the same wifi as all the other devices. Yet this still does not discover.

True… I thought there was some upnp binding I used before that might have enabled that sort of discovery but I can’t see it anywhere. There are some benefits to using files in that you have greater control of the names, etc and if you start a new system, it’s all pre-done. I assume you know all the device ID’s so you could just increment each line, etc.

I have started down this path, but like I mentioned its annoying in that I am learning via a steep learning of trial and error.

PS I’ve been burnt by jsondb corruption before and re-adding discovered devices is a pain (as you have to put in their friendly name, location, etc)

I have lots of TP-Link Kasa wifi switches and plugs, and new ones get auto-discovered immediately after I add them to my network via the Kasa app. I’m using the 2.5 beta binding, which @hilbrand has put on Eclipse Marketplace. Installation instructions here:

Auto-discovery worked for me on the 2.4 binding, so I’m honestly not sure if this will do anything.

Regarding the August lock, it seems that the only way to directly control it with OH is with a Z-Wave controller. There was a recent discussion about using the August Connect wifi with a Python script, but there’s no binding for it.

Tplink discovery works via UDP broadcast and port 9999. The devices must be in the same subnet, e.g. 192.168.0.x otherwise discovery won’t work. Also check your logs to see if there is anything reported (accessable via openHAB dashboard). In case this doesn’t show anything it might be an idea to set log level in karaf console (log:set TRACE org.openhab.binding.tplinksmarthome , and disable afterwords withlog:set DEFAULT org.openhab.binding.tplinksmarthome.
The static ip’s should not be a problem, actually the binding is able to handle ip changes.

Since you mention it, is it better/worse/same to use static or dynamic IPs? I started assigning static IPs years ago, because doing so made Belkin Wemo devices more reliable. I continued doing so after I moved to Kasa devices, more out of habit than anything else.

For tplink I don’t think is much difference between static and dynamic ip. Static makes sure it will never be a problem if some application might not handle ip changes well, but requires more configuration on the router/switch. For the binding it makes no difference if configured via discovery or with the device id.

On every change to the db a backup gets created. So if you do experience jsondb corruption you can restore from the backup (/var/lib/openhab2/jsondb/backups).

I don’t think a lot of users realize this so want to make sure it’s clear when I see comments like this.

I appreciate the tip, but I did try that as well as diff’ing the various versions. The items were in the file, but it appeared that openhab read up to a point then failed to read the rest. They would sometimes come back after multiple reboots (often once enabling trace debugging - classic) Since nobody else seemed to have the issue I just moved to file.