Autodiscover in binding that requires bridge which cannot be discovered

Tags: #<Tag:0x00007f746168d850>

I’m currently working on my Hive Home binding and have updated it to the new build system and registered my autodiscovery service but i’ve got a bit of an issue.

The binding requires a manually added bridge before it can autodiscover anything as it needs a username/password to talk to the Hive API. However, I can’t seem to find out how to disable the discovery scan when there isn’t a bridge.

When you add from the inbox and select the binding it scans for some time despite me returning immediately from startscan when there is no bridge present. Is there any way for me to stop it doing this and go straight to the add manually screen?

I would look at how some of the bindings that have the same problem have solved that. I know the Danfoss HRV binding (not official but in the community if you search) cannot be autodiscovered.

I don’t think the knx binding will autodiscover any interfaces and that is official.

1 Like

See my comments on your pull request.

1 Like