AVM Fritz Binding

Hey,

I have a problem with the avmFritzbox Binding.

I installed the Box and things like this:

Bridge avmfritz:fritzbox:7530ax "FRITZ!Box" [ ipAddress="192.ddd.ddd.eee", password="xxxxxxxx", user="xxxxxxx" ] {

    Thing Comet_DECT 	xxxxxxxxxxxx 	"Thermostat Wohnzimmer1" @ "Wohnzimmer"			[ ain="xxxxxxxxxxxxx" ]
}

It works like a charm and the things showing up in opanhab.

But if I’m connecting the items like this in my script:

// Schlafzimmer
Group gHeaterBed    "Thermostat Schlafzimmer"   {alexa="Thermostat"}
String              Thermostat_Schlafzimmer_Modus                      "Auto/Manuell: [%s]"                     <radiator>             (gHeaterBed) {channel="avmfritz:Comet_DECT:7530ax:xxxxxxxxxx:mode", alexa="Mode" ["MANUAL" = "Manuell", "AUTOMATIC"="Automatik" , "VACATION" ="Urlaub"]}

And unfortunately the items does not show up in openhab. And they work with the sitemap too, that I can control them via openhab app and so on. Then i tried to connect them with Alexa with the Metadata with works fine with lights but not with the thermostats.
Has anybody an idea how to fix that?

Thank you.

Just to make sure if I understood correct:

You have installed the binding & all your items are working correctly when you control them with the oh user interface? What’s you oh version?

What is not working is the Alexa integration for the thermostat?

If that’s the case, maybe change your title to include something related to Alexa and not only related to avm.

Please describe what’s (not) working?
Can Alexa discover the device but you cannot control it? Or is the discovery already failing?

Also include your full item definition for all thermostat related items and the group, not only the group and the mode …

Hey,

thank you.
I solved it. I used some wrong Meta data for the item and I think that was the reason why Alexa could not find it.

Thank you!