Basic UI not Live Updating openHAB 3.4.0.M6

Hey all,

Just wondering if this is a bug or not.

I updated from openHAB 3.3.0.SNAPSHOT → openHAB 3.4.0.M6 on a Windows 10 install. ( This was a fresh install not a Powershell update.)

Live updates no longer work on Basic UI . I have to manually refresh the page and they show the correct state. Any idea if there was something that changed with the new Milesone.

I have tried multiple browswers and same thing happens. Once I refresh the new status shows.


Anyone else having this issue? Just Updated to v 3.4.1 to see if that helps anything

Same thing is happening on the OpenHAB-3.4.1 Stable Version.


Does anyone know if I want to try another install which folder/s do I need to backup and copy over. I want to keep persistence, system configs, added Items through UI, etc. Do I only need to copy over the conf and userdata folders ?


In the runtime\bin directory you should be able to find backup.bat and restore.bat.
Running them with the argument /? should print their usages.
This will backup the OH configuration, OH userdata and depending ( ! ) on which persistence service you use persistence data as well.
Backup is stored in a .zip file.
Create a backup and check it’s content by browsing through the zip file or listing its content so you can check if everything is included that you need.

Still works for me. Just verified with OH 3.4.

There were no changes in Basic UI since a very long time that could have broken the live update.

What OH version were you running when it worked for you?