BasicUI not updating anymore

I have installed openhab 2 via apt-get and set it to update every day.
This wasn’t a problem until a few days ago: I noticed that some of my configurations and bindings were lost after each update (see also All settings lost after an apt-get upgrade).
So I switched from the semi-database configuration via PaperUI to the old (but working!) text configuration approach.
Since then BasicUI is not showing changes of values anymore without reloading the (whole) page.
With habdroid and ClassicUI all is working as expected.

Do you have any idea which setting could be responsible for this behaviour? The logs don’t show any error or warning. I can set values via BasicUI without problems - when I open the ClassicUI next to BasicUI I can see all changes to parameters changed via BasicUI immediately, so the UI elements still work.

The following gif shows the BasicUI on the left and the ClassicUI on the right.

There were many fixes in the Basic UI regarding this in the last weeks and to my knowledge, it now works all fine.
If you can confirm that you are on the latest distro, please enter an issue at and give an easy reproducible example (best using the demo setup) on how to reproduce your problem.

I digged into the problem by disabling all my rules/items etc. and enabling them one at a time.

The demo sitemap (sometimes) works as expected; I am not able to reproduce the error reliably.
Interestingly though, the debug log shows GET requests and sending of sitemap events

Received HTTP GET request at 'sitemaps/demo/0202'
Sent sitemap event for widget XXX to subscription XXX

when changing values within the demo sitemap but not when using my own sitemap, so there has to be some kind of difference between the two.

I couldn’t narrow it down to a single file, though, for now even the demo sitemap stops to work “randomly”, even if I disable all of my own config files. Reloading the site then leads to aborted requests (as listed in FireBug): it takes 2-4 tries to load the page with ~60seconds per try. The last request takes the usual <1sec to load the page. My own sitemap never works (it loads, but it shows the behaviour described above).
Top shows no unusual CPU usage during these times and there are also no unusual log entries to be seen (using tail -f /var/log/openhab2/openhab.log -f /var/log/openhab2/events.log and all relevant log items set to DEBUG)

At least now I have a tool for quickly enabling/disabling of rules etc. so I got that going for me, which is nice.

Currently I am using build #560 offline from the repo

Is your own sitemap called the same as the filename of it? (i.e. test.sitemap has the content “sitemap test…”)? If this is not in sync, the updating is broken.

1 Like

I just found out 5 minutes ago that the file and the sitemap name differed in one upper/lower case letter while I tried the sitemap with the tedious Edge-browser. This lead to some error 404 debug messages in the log.

I also changed the encoding of all config files to UTF-8 without BOM, it doesn’t work with BOM and it doesn’t work with ANSI.

Now it is working with edge but still nothing in Firefox.

Seems to be a browser issue and not an openhab one.

EDIT: now it doesn’t work anymore - neither with Edge nor with Firefox. Also there is still the issue with occasional, huge loading times. Still have to dig deeper.

EDIT2: now it works with Firefox and Edge - after some changes of parameters it stops to work, I then have to reload the page which takes a very long time. The logs are quiet during this time, only to be flooded with all actions I wanted it to perform afterwards.

Something is terribly wrong, even apt-get purge doesn’t help here.

I’d suggest to do testing on a clean fresh install using the zipped (or tar.gz) version.

I’ve noticed this issue too. I am on snapshot version 201610252044. My sitemap matches the name of the file name. I need to pull up the developer tools for the browser, but I do know that this issue is happening on Chrome.

For me all is now working again. I don’t know why, to be honest.
I did a fresh install with apt-get purge (as I did several times before) and changed all logging to ERROR level. Maybe the massive logging amount with all set to DEBUG caused my system to struggle?
For now my only problem is Sytem Info stuck on initializing, which isn’t related to this topic, I guess.
I will observe the behaviour and keep this topic updated/start an issue if needed.
Sometimes there was definitely something going on within openhab, which kept it busy for a long period without telling me what caused it and why. This behaviour - which was related to the unresponsive UI somehow - seems to be gone after the latest reinstall.

this fixed it for me