Bazillion "Could not remove element: null" errors

Hi everyone,

I’ve been having these errors popping up when I launch openHAB recently. 127 of them, all identical, appearing in the log right after OH finishes initializing.

2016-06-16 09:32:39.805 [WARN ] [ore.common.registry.AbstractRegistry] - Could not remove element: null
java.lang.NullPointerException
	at org.eclipse.smarthome.core.internal.items.ItemRegistryImpl.onRemoveElement(ItemRegistryImpl.java:302)[98:org.eclipse.smarthome.core:0.8.0.201605171440]
	at org.eclipse.smarthome.core.internal.items.ItemRegistryImpl.onRemoveElement(ItemRegistryImpl.java:1)[98:org.eclipse.smarthome.core:0.8.0.201605171440]
	at org.eclipse.smarthome.core.common.registry.AbstractRegistry.removed(AbstractRegistry.java:80)[98:org.eclipse.smarthome.core:0.8.0.201605171440]
	at org.eclipse.smarthome.core.thing.internal.ChannelItemProvider$3.added(ChannelItemProvider.java:268)[104:org.eclipse.smarthome.core.thing:0.8.0.201605171440]
	at org.eclipse.smarthome.core.thing.internal.ChannelItemProvider$3.added(ChannelItemProvider.java:1)[104:org.eclipse.smarthome.core.thing:0.8.0.201605171440]
	at org.eclipse.smarthome.core.internal.items.ItemRegistryImpl.allItemsChanged(ItemRegistryImpl.java:98)[98:org.eclipse.smarthome.core:0.8.0.201605171440]
	at org.eclipse.smarthome.model.item.internal.GenericItemProvider.modelChanged(GenericItemProvider.java:407)[118:org.eclipse.smarthome.model.item:0.8.0.201605171440]
	at org.eclipse.smarthome.model.core.internal.ModelRepositoryImpl.notifyListeners(ModelRepositoryImpl.java:201)[117:org.eclipse.smarthome.model.core:0.8.0.201605171440]
	at org.eclipse.smarthome.model.core.internal.ModelRepositoryImpl.addOrRefreshModel(ModelRepositoryImpl.java:97)[117:org.eclipse.smarthome.model.core:0.8.0.201605171440]
	at org.eclipse.smarthome.model.core.internal.folder.FolderObserver.checkFile(FolderObserver.java:240)[117:org.eclipse.smarthome.model.core:0.8.0.201605171440]
	at org.eclipse.smarthome.model.core.internal.folder.FolderObserver.notifyUpdateToModelRepo(FolderObserver.java:169)[117:org.eclipse.smarthome.model.core:0.8.0.201605171440]
	at org.eclipse.smarthome.model.core.internal.folder.FolderObserver.updated(FolderObserver.java:150)[117:org.eclipse.smarthome.model.core:0.8.0.201605171440]
	at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updated(ManagedServiceTracker.java:189)[7:org.apache.felix.configadmin:1.8.8]
	at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:152)[7:org.apache.felix.configadmin:1.8.8]
	at org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:85)[7:org.apache.felix.configadmin:1.8.8]
	at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1444)[7:org.apache.felix.configadmin:1.8.8]
	at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1400)[7:org.apache.felix.configadmin:1.8.8]
	at org.apache.felix.cm.impl.UpdateThread.run0(UpdateThread.java:143)[7:org.apache.felix.configadmin:1.8.8]
	at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:110)[7:org.apache.felix.configadmin:1.8.8]
	at java.lang.Thread.run(Thread.java:745)[:1.8.0_60]

Any rough ideas of what can create these errors? The only two other errors in the log file are regarding the KNX and XBMC bindings timing out, something I expect as I am testing outside of the actual deployment environment and as such don’t have the same network configuration. Could these timeouts create this torrent of warnings?

Thanks,
rally