Benext Energy Switch detected as thing type unknown device

Hi all,

I’m running OH3 on a RPi.
I have been trying to couple z-wave devices to my setup, using an Aeotec Z-stick Gen5+ as a controller. This has been successful for 2 (Aeotec MultiSensor 6 and Neo Coolcam smartplug) devices. However, the third device is detected but the thing type is not recognized. In thing configuration i see the following: Z-Wave Node 002 (008A:0006:0200:1.9)

I checked the Z-wave database at, but it is not clear to me if this device is now in this database correctly or not.

If I enable the debug logging I see the following log showing up:

2021-04-05 14:02:17.945 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 008A:0006:0200::1.9

I’m rather new to OH3, so please let me know if I missed some crucial information in my help request.
Thanks for your support

I just searched and that exact device is not in the database which is why it is unknown. If you wish, you may add it to the community maintained database. Here is the guide.

1 Like

Hi Bruce,
Thanks for the quick reply. I will try to add this device to the database.
If I read the guide correctly I should make a ticket after registry to the database. I’m waiting now on approval.
Ill post here if I added the device.

1 Like

Be sure to push the button to request review when completed. That sends out an email to the database approvers. It must be approved before it is actually included in the database…

If you feel you need help, just give a shout out here.

EDIT: One other thing. For some reason, when importing the XML file the site gives an error. Just search the database and you can find the newly added device and complete the configuration.

I have received access to the database. I tried to add a new device and I get an error as you predicted, but I can’t find the device in the database. I used attached xml file to import the information: network_ce0cf1f8__node_2.xml (6.8 KB)

As my device is the same as the one that is already in the list I now asked for a modification of an existing entry: OpenSmartHouse Z-Wave Device Database

Are you sure it is the same? That is an old Z-Wave ( not Plus) device.

EDIT: Upon further checking, it is the same device. That is why the site would not let you create it.

WARNING: Device with these IDs is already in the database as BeNext, Energy Switch + and endpoints are already defined.

EDIT2: I see you ADDED your device to the existing entry. That might not be correct.

If adding it to the existing entry is not correct, what should I do then?
This is not clear to me from the guide.

The device likely is a newer device with new features.
I tried locating Z-Wave association group & config parameters on the device but they are not published on the zwave alliance’s site. Hopefully the vendor has another document somewhere.

You can find a manual for the device here (although in Dutch):

EDIT: looking at the manual in more detail (page 3), I now notice that I have the standard ‘Energy Switch’ version and not the ‘Energy Switch Plus’ version.

The difference between the plus & non-plus version is minimal, accordgin to the manual. In fact the image in our database is the non-plus one.

I verified from another open source project that your device appears to be similar enough to the existing entry so I just updated it.

1 Like

Hi Bruce,

Thanks for update, very much appreciated!
What should I do next to be able to couple this device?

You will need to install a snapshot version of the binding sometime after the database is exported. Chris will likely do that this weekend.

Hi Bruce,

Is the procedure to install this snapshot version for OH3 equal to OH2 as described on this FAQ: ?

You just need to upgrade the zwave binding to a snapshot version. Lately there have been mixed results using the script.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

There are manual instructions are in the README but basically, you uninstall the zwave binding and place the snapshot jar file in the addons directory. OH automatically installs it but is does not appear ih the UI list of installed bindings. be sure to remove the manually installed addon & add the binding back before upgrading OH.

This appears to be the best link for the latest OH 3.1.0 snapshot.

EDIT: Please stand by. It appears the latest OH 3 snapshots are incompatible with OH 3.0.x

EDIT2: 3.0.2 will be released in 2 weeks. I do not know at this time whether the compatibility will be resolved.

Hi Bruce, Thanks again for the support. I will wait 2 more weeks before testing this.

You are welcome. Currently I am a very frustrated Z-Wave user. Yesterday I received 2 products not yet in the database. I entered one last night and will test on a modified binding but there is no stable release that can be used to test an officially built binding.

I am currently weighing my personal options, unfortunately.

I’ve installed OH 3.0.2. now. Can you tell if the snapshot Z-wave binding is compatible with this version? I can’t find any related comments on this.

Last I heard the SNAPSHOT is only compatible with SNAPSHOTs later than the last MILESTONE. OSGi was updated breaking backward compatibility.

The zwave binding for 3.0.x has been updated but I do not know when there will be another 3.0.x build. There does not appear to be a 3.0.x chain set up in the Jenkins CI system.

Hi Bruce, today I tested the SNAPSHOT version and with that version the device is recognized correctly and I can control the device via Openhab.
Thanks again for all the support!

1 Like

You are welcome!
I am sad there is not currently a solution using a stable version. The official advice is to wait for 3.1.0 to be released :frowning: