BeNext Heating controller no values, new z-wave device troubles

Hi everyone,

Heads up first, this is my first post so excuse me for any ‘obvious’ questions.

I have a device which was not included in the wonderfull zwave device library of Chris,I googled a lot and found out maybe I could contribute by adding it myself. So I added my xml file to the database and added the required documentation from the device.

http://www.benext.eu/en/products/heating-control/

The device is now in the database and recognised by openhab. When I link any items to the channels though, no values are shown and in the logging the same sentence keeps repeating. My Log:

/var/log/openhab2/openhab.log.10:2017-01-21 20:03:59.458 [WARN ] [tocol.commandclass.ZWaveCommandClass] - NODE 49: Unsupported command class PROPRIETARY
/var/log/openhab2/openhab.log.10:2017-01-21 20:03:59.458 [ERROR] [ssage.ApplicationCommandMessageClass] - NODE 49: Unsupported zwave command class PROPRIETARY (0x88)
/var/log/openhab2/openhab.log.10:2017-01-21 20:03:59.459 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 49: Application Command Request (ALIVE:DONE)
/var/log/openhab2/openhab.log.10:2017-01-21 20:03:59.459 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 49: Starting initialisation from DONE

The values I would want to see in my interface are coming by in the log a few times, after which they stop occuring. For instance, there is a multilevel sensor function for temperature:

/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.746 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 49: Application Command Request (ALIVE:DYNAMIC_VALUES)
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.746 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 49: Incoming command class SENSOR_MULTILEVEL
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.747 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 49: Received COMMAND_CLASS_SENSOR_MULTILEVEL command V6
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.747 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 49: Sensor Multi Level REPORT received
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.747 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 49: Sensor Type = Temperature(1), Scale = 0
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.748 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 49: Sensor Value = 19.87
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.749 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 49: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.749 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 49: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 19.87
/var/log/openhab2/openhab.log.6:2017-01-22 09:07:37.749 [DEBUG] [erter.ZWaveMultiLevelSensorConverter] - NODE 49: No sensorType set for channel zwave:device:thuis:node49:sensor_temperature

Any ideas would be helpfull. Thanks in advance

I added a BeNext heating controller to my network today.

Device was properly recognized:

Line 44523: 2018-01-03 20:44:35.836 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 9: Checking zwave:benext_heatingcontrol_00_000
Line 44524: 2018-01-03 20:44:35.840 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 9: Device discovery resolved to thingType zwave:benext_heatingcontrol_00_000
Line 44684: 2018-01-03 20:44:57.191 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Controller status changed to ONLINE.
Line 44685: 2018-01-03 20:44:57.192 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Controller is ONLINE. Starting device initialisation.
Line 44686: 2018-01-03 20:44:57.280 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Updating node properties.
Line 44687: 2018-01-03 20:44:57.281 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Updating node properties. MAN=138
Line 44688: 2018-01-03 20:44:57.282 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Updating node properties. MAN=138. SET. Was 138
Line 44689: 2018-01-03 20:44:57.283 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Properties synchronised

I see no errors in the zwave debug log, but I doubt that there is any communication with the thing. What would be the lines in the debug that confirm that there is a communication ongoing?

Probably unrelated to the zwave binding:

  • I tried to add items in the paper UI, but they don’t appear in the “control view” in paper UI.
  • I tried to change the thing’s “location” from the paper UI, but this got me an Error 500 server error. When trying to save the location from habmin, there is no error, but the change is not saved.

I am aware that this quite a bunch of various / chaotic information. I am willing to invest a bit of time helping to debug / improve the binding for this device. Please let me know what I can do to best contribute. If there is some kind of a “how to contribute” guideline, feel free to point me in the right direction.

Yesterday I was making lots of changes from paperUI and habmin, causing a lot of chatter on the debug log. Now I haven’t made any changes for many hours and see:

2018-01-04 18:48:18.432 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Polling…

2018-01-04 18:48:18.435 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Polling deferred until initialisation complete

2018-01-04 19:18:18.432 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Polling…

2018-01-04 19:18:18.435 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Polling deferred until initialisation complete

OK, so the initialisation is not completed yet. What would be steps to motivate openHAB or the thing to proceed working on initialisation?

Today I decided to restart the zwave binding to see if this had any effect.

Using the log viewer at http://www.cd-jackson.com/index.php/openhab/zwave-log-viewer, I now see this for the BeNext controller node. I guess it says we same some form of communication ongoing.

I don’t manage to add items yet. I suspect that this is due to the fact that two temperature (room/outside) channels have the same name. When I link an item to the first one, it immediately links to the second channel as well. I am not sure how I can correct this.

I now deleted these two temperature items and created a new item, linked to one of the “setpoint” channels, will see if I can learn some more from this new configuration.

On Sunday my heating didn’t want to start up in the morning. I had “error” flashing on the display of the room thermostat, so I decided to remove the BeNext controller. All started working aftert that.

I will probably do new tests in summer. As long as I really need heating, this device is out.