Best way to install OH3 on a HYPERV VM?

Hello everyone,
I’m going to switch gradually to OH3, keeping my OH2 running.
Most of my servers are now virtualized on a HYPER-V server, and I’d like to install OH3 also on a VM, instead of my Raspberry PI.
All my linux VM are running on Debian amd64.

What’s the easiest way of installing OH3 on an amd64 linux ?
Is there a better linux distro to do so (ubuntu, debian ?)

I tried briefly with the two methods here (apt and openhabian) on a debian amd64 linux

and had all kind of issue (unsigned repo, missing apt packages)

I liked the openhabian sdcard way, simple and easy.
And also never found the proper way to install the frontail log viewer.

Any advice ?


I am running OH2 on a Debian Hyper-V server that was set up by my son. He downloaded a VM image to start. I have not yet moved my production environment to OH3.

Is your current environment using any USB connected sticks? normally Hyper-V VMs do not have access to host USB ports. For my particular Z-Wave USB stick we worked around that somewhat.

If I had it to do again, I might use Docker in the VM to ease upgrades & possibly rollbacks. That is a personal choice though and adds complexity.

EDIT: Is is possible, usually to install the openHABian scripts on Debian. I am not sure if they kept frontail integration for OH3. If I used Docker I would just use a Docker image to get that too,

For the USB stuff, i’ll keep my USB ZWave stick on the raspberry, with zigbee2mqtt, alongside my RTL-SDR Usb receiver with rtl_433 running

HyperV snapshots are sufficient for me in terms of backup and rollbacks.

Also a dockerized openhab may have some limitations. I’m not sure you can run Python scripts or other tweaks like that in the docker container. But at least you’re starting with a fully working OH3 environment.

I’ll look for working openhab VM on the net.


1 Like

I understand Microsoft has a good library of VMs available

l’ll try with a x86 debian instead, maybe the cause of my issues

Tangentially relevant info: I’m running OH3 in an LXC container with Proxmox as the hypervisor. The template for the container was Ubuntu 20.04, and I installed via the apt repository. All went seamlessly.

There have been some posts in the past few days about repository issues, so you may be running into those same issues?

(I’ve also put zigbee2mqtt into another LXC container on the same system, passing a cc2531 through. A little bit of a faff, but it’s working reliably now)

Incidentaly, i was running all my VM on proxmox before … it crashed (badly) after a failed weekly backup. i never managed to restart the hypervisor after that. After a few hours of sweat and swear, I gave up and rebuild most on my servers … not a good experience.

Yeah, that does sound terrible. I’ve kept everything in containers rather than VM’s, and so far so good. Time will tell!

I am running 64 bit fine Using Zulu Java.

It looks like they still support a Linux install of openHABian.

So far so good with the x86 version off debian and openhabian
Only issue I had, as before, was frontail not installing.
I had to manually “apt install npm” and then re-install from openhabian-config.
I guess it has something to do with latest node.js not being released in 32bits (?)

I was using container also, and I wish I had chosen full VM instead … it would have been so much easier to recover (with my knownledge)

Latest LTS nodejs & npm in 64 bit is here.

Latest nodejs & npm for 64 bit linux is here.