Best way to publish Groups to Alexa?

Hi Jeremy, no i dont and yes whilst setting this up theres alot of change so using my routines etc has all broken.

This is down to the way you are thinking - you need to understand that a Group is in Alexa is different to a Group in OpenHAB. As @jeshab has mentioned you could go the route of creating all the Group’s in Alexa but it can be quite time consuming to re-add all the devices any time you need to clear the Alexa devices list. It also can be quite confusing when looking at the Alexa app as it doesn’t have nested groups.

As an example, I have 3 zones on a ceiling which I have voice controlled using Alexa - outer, middle and inner. The outer zone has 8 spots, middle 4 spots and inner 2 spots. So, to be able to use an utterance of ‘Alexa, turn on the outer spots’ I need to have Alexa see this as a device. Therefore, in OpenHAB I create a group ‘gOuterSpots’ and assign it the Alexa endpoint Light. Now, with the way you are thinking you would just add the ‘On/Off’ or ‘Brightness’ items for those 8 spots - however, what we are doing is allowing Alexa to see a ‘device’ called ‘Outer Spots’ and hence I want to ensure that she knows what the separate channels are. Hence I create the sub groups (ie. ‘gOuterSpots_Switches’ and ‘gOuterSpots_Brightness’) and then put the relevant items for each Spot into those.

I know that the groups look a bit superfluous, however, hopefully you can understand that Alexa needs these to be able to see ‘a device’. The members of the groups are in effect the capabilities of the device and you only put in the items which match those capabilities.

Thanks Sunny, so what was missing was to add ‘All Inside Dimmers’ and ‘All Inside Switches’ to ‘All Inside Lights’ - this appears to turn all switches/dimmers off using ‘Alexa, turn off all inside lights’ ONLY if Alexa, powercontroller is set for gAllInsideLights HOWEVER

Whilst it works, Alexa says, please check the connection and power supply :confused:

If I change the top level group to endpoint.Light, it doesnt even get discovered nor work

Try setting the Metadata on the ‘gAllInsideLights’ using the code tab to the following:

value: Lighting
config: {}

Managed to get it working by using the code tab, but turn off all lights wont work. Only turn off all Inside or Outside lights :frowning:

That is most probably down to ‘All Lights’ being a key phrase in Alexa - you could try creating a routine in the Alexa app just for the ‘All Lights’

Yep! seems thats the only way. Thanks Sunny!