Binding channel linking wrong temp

Hi All

I have a temperature Item that is linked to a wave sensor channel. The item temperature is not equal to the sensor temp. I’m not sure what I have done wrong or what is happening here. Any ideas?

item definition:

Number    LivingRoom_Thermostat_CurrentTemp "LivingRoom Current Temp [%.1f °C]" (gLivingRoom_Thermostat,gHVAC_CurrentTemp,gTemperature) [ "CurrentTemperature" ] **{channel="zwave:device:512:node2:sensor_temperature"}**

ZWAVE sensor is reading:
“link”: “http://192.168.0.215:8080/rest/items/zwave_device_512_node2_sensor_temperature”,
"state": “28.6666666666666666666666666666667 °C”,
“stateDescription”: {
“pattern”: “%.1f %unit%”

Item reporting:
“link”: “http://192.168.0.215:8080/rest/items/LivingRoom_Thermostat_CurrentTemp”,
"state": “83.6”,
“stateDescription”: {
“pattern”: “%.1f °C”,

Thanks in advance,

Theo

You did not state your OH version, but the 2.4 zwave binding now uses UoM. You’ll need to define your Item to use it. Also, be sure to set your OH regional settings.

1 Like

I just had the same problem after updating to OH2.4. I did read about the change in the way units of measure are handled, but I didn’t find how to act on that. Thanks to 5iver calling UoM, I found this new part in the documentation: UoM-documentation

Most of it is way to complicated for me. But I did find out that for my temperature measurement not showing on sitemap, this addition in the items-file helped:
old: Number T_SP “Temperatuur” {channel…
new: Number T_SP "Temperatuur [%.1f %unit%]" {channel…

Hey @5iver and @Guido_van_Haasteren

I was running a milestone build and now a release of 2.4.

Thank you for pointing me in the right direction to UoM. That fixed my problem.:grinning: