Binding-miio - 2.5.3 Discovery empty

it’s my first post here, sorry if it’s a duplicate but I didn’t found any solution on the forum.

I have a Yeelight Color Bulb. In the past I connected it via the Yeelight Binding. But then it lost connection after a few days. After a restart, it worked again for some time.

So I try the miio binding.

After installing the binding the inbox is empty. So I tried adding the thing manually.

I have already discoverd the token and my thing configuration looks like this:

Thing miio:basic:light22 "My Light" [ host="", token="7df328346c38b071076886d3260e2306"  ]

But I get this error in the log:
miio:basic:light22’ changed from ONLINE to OFFLINE (CONFIGURATION_ERROR)

Maybe the deviceID is missing, but I have no idea where I can find it.

Thanks for your help and for your work!

Did you try setting the IP address as static/reserved in your router?

Do a Google search for how to get the device ID.

Yes, I have tried both, dynamic and static IP.

On Google I haven’t find anything. There are a lots of tutorials how to get the token, but nothing about the device ID.

I have also tried it this way:

Thing miio:basic:light22 "My Light" [ host="", token="7df328346c38b071076886d3260e2306" , deviceId=" "  ]

But with the same result.

What is the bulb model number?

Yeelight LED Bulb (Color)2

From the Doc’s:
“Newer devices may not yet be supported. However, many devices share large similarities with existing devices. The binding allows to try/test if your new device is working with database files of older devices as well. For this, first remove your unsupported thing. Manually add a miio:basic thing. Besides the regular configuration (like ip address, token) the modelId needs to be provided. Normally the modelId is populated with the model of your device, however in this case, use the modelId of a similar device. Look at the openhab forum, or the openhab github repository for the modelId of similar devices.”

Try using a similar devices ID or do the following:

For Linux users

  • Yeelight app
  • Python and Pip installed
  1. Open Yeelight app and run “Lan Control” as described here:
  2. in Linux Terminal run “sudo pip install yeelight” to import yeelight library for python
  3. In linux Terminal run “python” to access to the python console (terminal now prompts “>>>”)
  4. type “from yeelight import discover_bulbs” and press enter
  5. type discover_bulbs() and press enter (lan control in yeelight up must be activated).
    Instrunctions here:

After few seconds the console prompts something like this (at the bottom of the image you can see the deviceid):

I’m sorry. But unfortunately my knowledge of Linux is not enough. I didn’t make it work.
But thanks for the tip.

I have two other yeelight bulbs with the same firmeware and both of them are working fine.

So I’ll sort out the other one and order a new one.