Binding not initializing [SOLVED]

Tags: #<Tag:0x00007f2fb0eec488>

I’m developing a binding for the Shelly series of devices. The first version has already be released and various people could successful install and use it - all good for them.

However, 2 people are reporting the following problem:

  • fresh OH install on Windows + GSon 2.8.2
  • set log to TRACE for that binding
  • copy binding to addons folder
  • and…nothing happens
  • but also openhab.log shows zero entries

We tried things clear cache etc., I added try-catch (Throwable e) on each of the initialization procedures, the binding uses only the http transport. Nothing worked or at least showed some problems in the log. We also tried a 2.4 and 2.5 build - same.

Does someone has an idea? Is it possible to Debug the bundle loader?

It could be that a dependency of the binding is not loaded.

In the Karaf console, try stopping and starting the binding. If there’s a missing dependency, it’ll be reported when you try to start the binding.

Yes that’s what we tried first. But the binding doesn’t show up at all - not in bundle:list, not in the log

Did they download the binding jar file from GitHub? If so, check to make sure they actually downloaded the jar file, not the HTML.

Could be an idea. They said they did, but maybe a miss-understanding - will double check

great, it seems that’s the problem - you are smart :rofl::ok_hand:
sometimes the simplest things are the ones we don’t see :slight_smile:

Only because I’ve done the same thing myself. LOL

it’s never too late to get to the next level :slight_smile: