Bindings .kar file won't install OH2 PaperUI

Many hours (days) lost while trying to install the Panasonic .jar
I have re-installed the latest OH2 on my QNAP.
I have added the openhab-addons-2.0.0.kar to my addons file, but when I go into the PaperUI the new bindings are not there.
They do appear to have been extracted to /share/CACHEDEV1_DATA/.qpkg/openHAB/distribution/userdata/kar/openhab-addons-2.0.0/org/openhab/binding
Does anyone know why, and does anyone know where the actual Bindings (ie the ones in the Paper UI list) are stored?

I am finding OpenHab very demanding/frustrating, does anyonw know any good websites for advice, the openhab site is just not keeping up with good enough support for the releases? There is lots of potential, but I am close to giving up.

What do you mean “are not there”?
You don’t see any Binding available to be installed in PaperUI->Add-ons->Bindings?
Placing the openhab-addons-2.0.0.kar file in the /usr/share/openhab2/addons/ folder will not install the bindings. Installation (and then configuration) of a Binding is an extra step that you must perform.

Thanks for your interest in this question. When I select Addons in the Paper UI, only the original Bindings (those installed with Openhab2) are visible, so for example the Panasonic Binding which is within the .kar file, is not in the list of Addons. It would be good to know where the Addons list gets its data from, ie. where is the look up and where are the jar files stored.

Have you disabled the “Access Remote Repository” option in PaperUI?

In theory, all should be visible and available for installation… Which Bindings appear?

If you deploy a *.jar file manually for a Binding, it will not show up in PaperUI.

Check also your addons.cfg file and set package = expert in there to see if things improve

I had tried the “Access Remote Repository”, but it made no differrence. Which is the addons.cfg file I need to alter? I have found one in /share/CACHEDEV1_DATA/.qpkg/openHAB/distribution/conf/services , but all the lines start with a #, so I assume they are comments. I have made an assumption that the file I need to change is addons.config (/share/CACHEDEV1_DATA/.qpkg/openHAB/distribution/userdata/config/org/openhab), but this makes no difference. I tried rebooting the server, but this file set itself back to simple. Is there a way to run the start up options again without reinstalling, so I can try using a different mode other than simple?

Below is a screenshot of my configs page, so you can see the Panasonic Binding is not present.

Below is a screenshot of my file structure showing the kar directory.

Any advice is appreciated, thanks.

Update to post: Further info after more searching through the files…
I have found the org.openhab.addons.cfg (in /share/CACHEDEV1_DATA/.qpkg/openHAB/distribution/userdata/etc) and modified this, and now have the Panasonic Binding available.

It seems you got the same problem like me : Link @Dim I have enabled both of them, but it does not work.
It seems to be an old problem: Link

Hi Vertux,

Did you see my post update? I have found another addons.cfg, and this has allowed the Panasonic Binding to appear. I have now installed it, but it does not appear to have found my TV (yesterday, OH2 detected my Samsung TV almost instantly); another afternoon planned playing with this.

@Blue_Moon_23 Thank you for the hint, I have overlooked your update. On my Raspi the file can be found in /var/lib/openhab2/etc/ but it does not solve the problem.

Update: I have modified /etc/openhab2/services/addons.cfg - although the comment in the file says:

Note: This is only regarded at the VERY FIRST START of openHAB

As if by magic all missing bindings suddenly appeared in the GUI - two binding tabs become seven, that’s crazy.

1 Like