Bosch Indego, How to use Bosch single ID

How to use the Bosch single ID is described in the binding under Authorization:

  • “Please wait…” should now be displayed.
  • Find the authresp and copy the code:<copy this>
    …but I’ve couldn’t find this code in the page!
    I’ve only found this:

Please, would someone kindly help me?

Best regards

In Chrome:

Log in with SingleKey ID. Then the code will appear here:

Many thanks, Jacob!

I will try it.

Today I tried it, but something get wrong:

Any idea? It would be great!

Did you already installed the boschindego binding? Guess you’re missing that one in OH4?

ps topic & screenshots helped me to identify the correct code. Mine is online…

Unfortunately, I’ve installed the binding by a file. But I’m not able to remove it:

I think, that’s the problem. But I couldn’t find the file.

What can I do in this case?

Now I’m reinstalled the binding, but always the console said this:

What could be wrong?

You need to upgrade to milestone 2. Please also mind the upgrade notes:

Indego Binding: Due to changes in the cloud services, the authentication method has changed. Please follow the authorization flow described in the documentation. Furthermore, a bridge is now required and must be assigned to the indego thing. Configuration of username and password is no longer required/supported.

can you tell me how I can authorize with SingleID?
After installing the binding, I get a bridge with label SingleKeyID, but there are no information how to connect or how to authorize, so it is unauthorized:

See Bosch Indego - Bindings | openHAB

Doesn’t work for me, I get an authorization error: Failed to authorize by authorizsation code…

Any ideas to solve this problem?

Please describe in details what you have done. Have you had a look at previous posts in this thread where some additional instructions are given?

I don’t see any additional instructions… sorry.
I did the following:

I don’t also understand what you meen with “you need to upgrade to milestone 2”. Yesterday I made a complete new installation of openhab3, so I think all add-ons etc are up-to-date.

There is a “d” too much here, command is “authorize”.

Yes, of cause… it is a typo here… not in console. Sorry. in Console i typed openhab:boschindego authorize “code” and get the message “Authorization error: Failed to authorize by authorizsation code…”.

And the full code was copied, starting with “ey” and ending with “yg” from your screenshot? Also, please mind that the code is only valid for 10 minutes, so the command must be run right after getting the code.

Yes, I copied the full code and this between a few minutes, but definitively less than 10 minutes. I think I copied between 2 minutes because I logged in before visiting the website etc.

Can you try again and paste the console output from when you enter the command and until you get the response?

Got it.
My way was the following:

  • deinstall binding and reboot oh
  • authorize BEFORE adding single key id thing
  • add single key is as thing
  • authorize again

Thank you for your help!


since yesterday (at least that’s when I realized it) the authorization keeps failing with this error:

2023-11-05 09:59:35.974 [INFO ] [internal.handler.BoschAccountHandler] - Attempting to authorize using authorization code
2023-11-05 09:59:36.327 [INFO ] [internal.handler.BoschAccountHandler] - Authorization completed successfully
==> /mnt/usb1/log/openhab/events.log <==
2023-11-05 09:59:36.330 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'boschindego:account:d81d6c15e3' changed from ONLINE to ONLINE: Authorization completed
2023-11-05 09:59:36.332 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'boschindego:indego:d81d6c15e3:560d2b3403' changed from OFFLINE (COMMUNICATION_ERROR): The request failed with error: 403 to UNKNOWN
2023-11-05 09:59:36.332 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'boschindego:indego:d81d6c15e3:a568d7d68e' changed from OFFLINE (COMMUNICATION_ERROR): The request failed with error: 403 to UNKNOWN
2023-11-05 09:59:36.338 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'boschindego:account:d81d6c15e3' changed from ONLINE: Authorization completed to ONLINE
2023-11-05 09:59:36.522 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'boschindego:indego:d81d6c15e3:560d2b3403' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): The request failed with error: 403
2023-11-05 09:59:36.523 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'boschindego:indego:d81d6c15e3:a568d7d68e' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): The request failed with error: 403

It worked for quite some time now, and on commandline I also do not get an error when I authorize the bridge:

openhab> openhab:boschindego authorize eyJraWQiOiJoYURfVWlBTXE3Q2t4WXpGRUp .... many other characters ... w.MVuMZyUSowpyYz9Q5DvJOA

Did Bosch change something in the authorization again?

I also tried to create a new thing - but this also didn’t help.