Broadlink binding [4.1.0;4.2.0)

UPD: My bad, I download not RAW jar.

Hi,

Do not use bundle:install. Put the jar file in the right directory instead.

Updated the alpha and beta versions of the broadlink binding.

@ricardol I have finished the clean-up and pushed it to the PR. There is an issue with the openhab CI, you used an incorrect format for your commit messages. See [Broadlink] Initial contribution by AntonJansen · Pull Request #16273 · openhab/openhab-addons · GitHub can you fix this in the broadlink-binding-4.2.x branch?

See Changing git commit message after push (given that no one pulled from remote) - Stack Overflow how you can change selected commit messages.

Hello Friends,

Until yesterday I used the unofficial Broadlink binding for OpenHAB with my RM4 Pro and it worked great for sending RF commands.

However, after I updated my OpenHAB docker container to version 4.1.2, I now can’t send RF commands and the Thing I created for the RM4 Pro is showing an ERROR: HANDLER message.

Can this Broadlink Binding work with the RM4 Pro? (I didn’t see the RM4 Pro listed in the documentation as a supported device, and I cannot find it when I run a manual binding scan).

Hope someone can help :pray:

Yes, it can

1 Like

Hi @AntonJansen , thank you for your reply :pray:

After I created the RM4 Pro Thing, I only see one IR related learning channel? Is that how it should be also for the RM4 Pro?

From the documentation I got the impressions there should also be a separate Learn RF Code channel, but I don’t have that.

For IR find the Remote Learning Control channel and create an Item for it, for RF use the Remote RF Learning Control channel instead (Only needed the first time).

I also created a string Item for codes learning (as instructed in the documentation), but there is no option to “click” the NULL square to put the RM4 Pro into learning mode, and no popup menu appears.

Click the item, and click the rectangular area that is marked NULL
In the pop-up menu that appears, select Delete IR command for IR or Delete RF command for RF

Am I missing something? Or maybe the documentation wasn’t updated to new developments of the binding?

@AntonJansen Is it mandatory for the Broadlink binding to work that I also connect my RM4 Pro to the official Broadlink mobile app?
Last time I used the official Broadlink app with my RM4 Pro was around 3 years ago.

I think something already went wrong when creating the thing. In the official broadlink app you need to “unlock” the device for the binding to work. The scan should then be able to pick up your device. Could you share a screenshot of the thing tab of your “Broadlink RM 4 Pro” thing? In particular, can you expand the “Thing properties”?

I tried following your suggestions.
The Thing I created earlier did not have the option to show the Thing Properties.
As such I followed the next steps:

  1. I deleted the Thing.
  2. I then added the RM4 Pro into the official Broadlink app for iOS.
  3. In the Broadlink app I disabled the Lock Device toggle.
  4. The app asked me if I want to upgrade the device firmware, but I pressed “no”.
  5. I tried to re-add the Thing to OpenHAB, but the scan function still could not find it.

Hmmm, that is strange the RM4 Pro I have just shows up. It uses firmware version 62093.

My RM4 Pro is currently on firmware version: 52074.
The update version available to install is: 52079.
Should I update to the latest version?

[Edit] I updated the device to firmware 52079, but the binding’s scan still doesn’t find it.

Hi @AntonJansen,

I hoping you could help me, I installed the above JAR file and was able to add my RM4 pro as a thing successfully.

I tried to follow the learning instructions, but when I get to the item page an try clicking on the null, no menu was available when clicking the NULL.

If I try the command item, the Null is can be clicked and menu comes up with only “cancel” option.

I am running Openhab 4.1.2 as docker image on synology NAS.

Do you have any suggestions?

Hi @rharman , can you please explain what you mean by installing “the above JAR file”?
Is the plugin’s JAR file not installed automatically when installing the binding from the add-on store?

Hi,

By install, I mean I downloaded the jar from the link at the top of this thread and place it in the add-on folder.

I don’t think this add-on is available for me to install as I am running openhab 4.1.2.

Thanks

Thank you, @rharman
This clears up a few things.

@AntonJansen I accidentally tried to add the RM4 Pro as a thing using the Broadlink Binding plugin from the add-on store. It might be helpful for future users to clearly write in your documentation that we need to manually add the JAR file into the addons folder, and not install the official Broadlink binding currently available on the add-on store.

So I deleted the binding from the add-on store, and I manually added your JAR file to the addons folder.

Now that I have the correct binding file, how do I add the Thing?
My OpenHAB system is not showing me my RM4 device as available to add, and I’m not sure where I should look for it?

@mjeshurun this explains some things :-).

To add a thing do the following:

  1. Settings → Things
  2. Press + symbol in the lower right of the screen
  3. Click on the “broadlink binding”
  4. Click on scan
  5. Click on the device to add

If not detected, manually add the device by clickling on the “Broadlink RM4 Pro”.

  • Add the IP address in the network address field
  • Add the MAC address in the mac address field
    Click on “Create Thing”

Thank you.
That’s what I thought I should do, but the Broadlink Binding is not showing up in the list of available bindings – even though I copied the JAR file into the docker appdata/openhab/addons folder and restarted OpenHAB.

@AntonJansen do you, by chance, have an idea why OpenHAB fails to start/load the binding?

Some thoughts:

  1. Make sure you have downloaded the raw version of the jar file. Check this by opening the jar file as a zip file. If this does not work, you do not have the right jar file.
  2. Check if you are using the right location as described here.
  3. Check if the jar file has the right permissions for openhab to read the file
  4. Turn on logging for “org.openhab.binding.broadlink” and see what goes wrong.

Thank you for the detailed steps :pray:

  1. I downloaded the jar file from shown on your OP Resources links on this page.
    I checked and am able to rename the .jar file to .zip and open the folder.

  2. I copied the jar file into the same addons folder the old broadlink binding jar file was located. For me it’s /mnt/user/appdata/openhab/addons

  3. which ownership/permissions does openhab need to read the file?
    Currently the .jar file has the following:
    Owner: UNKNOWN
    Permissions: -rwxrwxrwx

  4. can you please explain how I can turn on logging for “org.openhab.binding.broadlink”?