Broken: Chamberlain MyQ has changed something

I got a notification to update my Chamberlain MyQ iOS App because they changed their interfaces, and sure enough, the MyQ binding is now broken:

2017-01-27 18:14:27.669 [ERROR] [nhab.binding.myq.internal.MyqBinding] - Could not connect to MyQ service Null response from MyQ server
	at org.openhab.binding.myq.internal.MyqData.request([178:org.openhab.binding.myq:1.9.0.b5]
	at org.openhab.binding.myq.internal.MyqData.getMyqData([178:org.openhab.binding.myq:1.9.0.b5]
	at org.openhab.binding.myq.internal.MyqBinding.poll([178:org.openhab.binding.myq:1.9.0.b5]
	at org.openhab.binding.myq.internal.MyqBinding.access$0([178:org.openhab.binding.myq:1.9.0.b5]
	at org.openhab.binding.myq.internal.MyqBinding$[178:org.openhab.binding.myq:1.9.0.b5]
	at java.util.concurrent.Executors$[:1.8.0_101]
	at java.util.concurrent.FutureTask.runAndReset([:1.8.0_101]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301([:1.8.0_101]
	at java.util.concurrent.ScheduledThreadPoolExecutor$[:1.8.0_101]
	at java.util.concurrent.ThreadPoolExecutor.runWorker([:1.8.0_101]
	at java.util.concurrent.ThreadPoolExecutor$[:1.8.0_101]

Any thoughts?

1 Like

Have you heard anything? Is yours still not working? I had to change my password on their site and I changed it in my services file but noticed it still wasn’t working. I guess we are in the same boat.

I’ve heard nothing… still broken :frowning:[settings][filter_by]=all&topic-reply-list[settings][page]=1#reply_18423574

Add another “me to”, though mine just went offline a couple of days ago.

It looks like the binding would have to be changed to do something like this.

Please add any useful problem information here:

Looks like,24715.675.html

Has it working again with the Vera but I don’t see the file they’re talking about.

I see that a patch has been merged into the code on Github, but I’m not sure how to get it onto my system. I loaded up the project in Eclipse Smart Home, but for the life of me I can’t figure out how to get it to compile the JAR file. I know that this is probably simple, but I’d really appreciate it if someone could point me in the right direction. Thanks.


I’m back up! Thanks so much for your help.

1 Like

Big thanks to Scott H. for his fix!

1 Like

Can you put up instructions for OH2, or preferably update the repository so PaperUI downloads this instead of the 1,9 version?

Here are the steps that worked for me:

  1. Uninstalled the MyQ binding via the Paper UI.
  2. Downloaded the JAR file from
  3. Placed the JAR file in /usr/share/openhab2/addons/
  4. Restarted OH 2 (/etc/init.d/openhab2 restart)

I hope that helps.


Thank you so much for not just the information, but your quick reply. It works perfectly. Also I can’t thank Scott H. enough for his hard work.

1 Like