Broken OpenHAB: Unable to install bindings with issue ERROR: Unable to resolve root: missing requirement [root]

  • Platform information:
    • Hardware: Raspberry Pi 4
    • OS: OpenHabian 1.5
    • Java Runtime Environment: ???
    • openHAB version: ???

I just broke my OpenHabian installation on my Raspberry Pi and need help fixing it. Here is what I did:

I was unable to install the Expire Binding. And was getting an error in the logs telling that it was unable to resolve a requirement (like the one below).

After googling it, I read in a forum post, that doing sudo openhab-cli clean-cache and rebooting (multiple times) might help.

However, after doing so I am now getting the same error for the UI-bindings as well and surely enough the web-UI are missing (see the log-output below).

Before this, I had installed already the ZigBee binding and gotten it to work. But I suspect that I might have done something wrong there, because it shows up in the error message (see below).

Any help on fixing this would be very welcome.

Note that this is mostly a fresh install, so a complete reinstall would not be a huge issue - but I would feel uneasy about not understanding what I did wrong and redoing it in the future (or at least knowing how to fix it).

This is the error message:

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-hue, openhab-ui-homebuilder, openhab-ui-basic, openhab-binding-expire1, openhab-ui-habpanel, openhab-ui-paper, openhab-binding-zigbee': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-zigbee; type=karaf.feature; version="[2.5.1,2.5.1]"; filter:="(&(osgi.identity=openhab-binding-zigbee)(type=karaf.feature)(version>=2.5.1)(version<=2.5.1))" [caused by: Unable to resolve openhab-binding-zigbee/2.5.1: missing requirement [openhab-binding-zigbee/2.5.1] osgi.identity; osgi.identity=org.openhab.binding.zigbee.cc2531; type=osgi.bundle; version="[2.5.2,2.5.2]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.binding.zigbee.cc2531/2.5.2: missing requirement [org.openhab.binding.zigbee.cc2531/2.5.2] osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.binding.zigbee.converter)" [caused by: Unable to resolve org.openhab.binding.zigbee/2.5.2: missing requirement [org.openhab.binding.zigbee/2.5.2] osgi.wiring.package; filter:="(&(osgi.wiring.package=com.zsmartsystems.zigbee)(version>=1.3.0)(!(version>=2.0.0)))"]]]

Based on your error message I’d guess you use 2.5.1 and remote addons that mismatch the version. Upgrading to latest (2.5.2) should resolve that (upgrading also cleans the cache).

I have the exact same issue, Expire and ZigBee binding seem to conflict. An upgrade to 2.5.2 is not a solution for me since it will break ZigBee in my case (using CC2531 USB stick). Just had to downgrade back to 2.5.1. in order to get Zigbee to work without serial buffer overruns. See this issue.

Upgrading to 2.5.2 solved the issue. So thank you for the solution @mstormi.

Do know and could you explain what was causing this issue in order to better understand it? Just for my understanding of the issue. Thanks in advance.

As I wrote based on the error message my guess was you have configured OH to download your addons which results in latest (2.5.2, that is), but the 2.5.1 core was expecting 2.5.1 addons.
@depto you might want to deploy the 2.5.1 openhab2-addons package (to use local .kar files instead of going to download them)

Same problem here with OH 2.5.3. Also other bindings give the same problem.

How can I stop OH from trying to install these bindings? It doesn’t seem to give up :confused:

Try remote=false in addons.cfg

Unfortunately this doesn’t stop OH from trying to install the failing addons. This repeats every minute:

2021-01-18 08:58:33.408 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-modbus, openhab-binding-kodi':

Is there no way to stop it?

If I wanted to install the exact version 2.5.3 of the openhab-addons package locally, how would I do this? (I am running openHABian in a RPi).

apt-cache madison openhab2
apt-get install openhab2=<version> version as per output of the 1st command

But you should upgrade to the most current OH2 first anyway, then you can also omit the =<version>

Thanks, this command did the trick:
apt-get install openhab2-addons=2.5.3-1

After that installation of the bindings with remote repos disabled worked.