bTicino cheaper gateway L4686SDK, F455 for 130 euro, MH201 for 52 euro

Tags: #<Tag:0x00007f616f5499d0>

Thanks massimo! The problemi now is that google or alexa doesnt recognize the blinds, only as dimmer but there isnt the stop button!

But one question: what is the difference from bticino binding?

did you try to read the example for rollershutter and required tags in the README? if yes, then write on the main thread to get help from others or open a new thread…

you should first read the intro and Features of the main thread…

Yes but I’m afraid blinds in alexa are not supporter yet in Italia…

you should find in the log these lines:

COM SENDING   ============>>>>>>>>>>>> *#13**15##
COM RECEIVED  <<<<<<<<<<<<============ *#13**15*200##

can you copy here your lines ?
The code after 15*, 200 in the example, is the server type code.
I am interested to know which code corresponds to MH201.

where should I put this configuration?

I installed OpenHAB 2.5.0.M4 with its “binding-bticino1 - 1.14.0.M4”, plus the “Eclipse IoT Market misc-market - 2.5.0.M4” and “OpenWebNet 2.x Binding (Beta) market:binding-4138499 - 1.0”.
When I go to Inbox and press the white ‘+’ on cyan background

I got this empty screen:


and I cannot go further.
The MH201 is right connected and MyHomeSuite see it and I can configure the devices on the bus

have you Activate Dependencies?

https://github.com/mvalla/openhab2-addons/blob/openwebnet-dev/bundles/org.openhab.binding.openwebnet/README_beta.md#2-activate-dependencies

using the Karaf console, I give the command:
feature:install openhab-transport-serial
and worked, but with command:
feature:install esh-io-transport-upnp
responded error

Hi @efa,
I just updated the installation instructions for openHAB 2.5.x:
the dependencies to be activated are:

  • feature:install openhab-transport-serial
  • and then
    • for openHAB 2.4.x:
      • feature:install esh-io-transport-upnp
    • or for openHAB 2.5.x and later:
      • feature:install openhab-core-io-transport-upnp

OK, now in Inbox I see:
MH201 (MH201, 1.0, 192.168.1.x)
BUS Gateway
aa:bb:cc:dd:ee:ff

Is it the right version of the plugin (from marketplace):
OpenWebNet 2.x Binding (Beta)
market:binding-4138499 - 1.0
?

In InBox if I press the white rolled arrow on cyan background,
after a minute with “Searching for Things…”, I got not Things found.

I tryed to manually configure two switches, ID and APL address. Just after configuration are marked as “UNKNOWN waiting state update…”, and after switching the light become ONLINE.

How to activate the automatic search with MH201?

1 Like

Did you add the found gateway from Inbox?does it show in the things tab? Is its status connected?
If the gateway is connected to openHAB but no devices have found then you should enable debug level logging (see README for info), start a new discovery and send me the log

1 Like

OK, what is not clear is that I had to press on the check tick (add) once the Gateway was discovered or the second scan in Inbox results in no other things found.
Once done the add tick, a new scan discovered 8 switch. I added all.
Then do a new scan and discovered another one switch.
Further scan results in no other switch. There are about 40x H4652/2 in my home.
Will enable debug and PM you the log

Valerio I encourage you to read first some basic openHAB documentation page. OpenHAB is not an easy system to be used without reading first (is not a commercial system) and support by the community is limited and volunteer-based: you cannot expect support especially if you do not do you homework first, demonstrating to read the basics.
Also if you have many devices I suggest you go for a file based configuration (things and item files).
Finally the device you mention is not a switch or actuator but It is a command (used for CEN/CEN+) , so it should not be discovered automatically but by activation.
See (again) the README for the CEN/CEN+ part. Search the community for examples of configuration.
In case of clear malfunction , get the logs and explain what is the expected behavior and what the system is doing instead.

Just for info, tomorrow I will get my mh201 and I add it to my bus. After that I start to add all button, roller and temp to openhab. I will keep you updated

I already used org.openhab.binding.openwebnet-2.5.0.M3 using a MH200N as gateway, and all is gone, even autodiscovery of the devices.
Now I tried to replicate all in another installation using MH201 as gateway, but only the BUS Gateway was discovered.
this is the log:
2020-01-19 17:00:52.154 [INFO ] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== ------ startScan() - SEARCHING for bridges…

2020-01-19 17:00:54.402 [INFO ] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== No serial ports found

2020-01-19 17:00:54.410 [INFO ] [al.discovery.BusGatewayUpnpDiscovery] - ==OWN:UPnP== — Found device # urn:schemas-bticino-it:device:IPscenariomodule:1

2020-01-19 17:00:54.416 [INFO ] [al.discovery.BusGatewayUpnpDiscovery] - ==OWN:UPnP== |- MH201 (BTicino S.p.A.)

2020-01-19 17:00:54.422 [INFO ] [al.discovery.BusGatewayUpnpDiscovery] - ==OWN:UPnP== Created a DiscoveryResult for gateway ‘MH201’ (UDN=upnp-IPscenarioModule-1_0-000350991EF0)

I have just set up my home with the MH201.
After push the " + " under INBOX and selected the Openwebgateway, i pressed every buttons in my system and Openhab find them.

@mvalla: autodiscover on mh201 ran only after upgrade to firmware 030306, maybe it will be useful to others.
autodiscover found all the switches, including the rolling shutters, but only the shutters are not visible by alexa.
need I need to configure them manually creating a .thing and .item element?