[BTicino/OpenWebNet] New openHAB2 binding ready for testing

Thank you Tony for the encouragement here and elsewhere. Massimo too.

It wasn’t so long ago I didn’t know what a Raspberry Pi was and now I have about 6 of them doing different jobs. They are so useful. Then along came thoughts on what to do to get my BTicino stuff to the next level and possibly working with non-BTicino stuff. I had a spare Pi and Openhab looked like a good bet. A few weeks later, after a bit of success with Openhab, I then thought Alexa could be a useful addition. Now I have voice alerts, voice commands to and from my BTicino BUS and Alexa is amusing for now. But there’s more to do and explore as these things develop.

I don’t know Linux or any other language. I have long forgotten Fortran 77 the only programming I ever did. With help I have picked up bits of useful code, commands and software tools as I go. So, if I can dive in and get a result in a reasonable time without much knowledge then anyone not afraid to learn something new can too.

I recognise that friendly support, tips and examples are key factors to encourage people to take the first few tentative steps. A friendly, supportive community is important for that. Later, newcomers have become experts and contribute as well. It’s one reason why I started my rather chatty threads on these topics over at the AVF site. People can see the journey and follow.

See link if anyone wants to join in: www.avforums.com home-automation-bticino-openwebnet-scs-bus

ps It did help that it rained a lot on my holiday :slight_smile:

1 Like

Hello All,
It’s strange, I’m used a Zigbee Automation Actuator Legrand 067263.
When i’m send a command :
UP => The actuator DOWN it’s NOK
DOWN : The actuator UP it’s NOK


Hi @tagada. Then please check that the connection of your device with the electric wire of the roller shutter is correct.
In fact if an UP command is sent in OH2 to a Automation thing, it is translated by the binding to a *2*1*WHERE## OWN command which contains the WHAT=1, which according to the specifications must be used for sending UP a shutter on the BUS/ZigBee side (UP means opening it).
I do not have shutters to test myself, but other users have tested the binding with shutter commands and it worked fine.
Did you ever tested your device with other apps or systems?

I tested with both my wireless and wired blinds. They work as expected.

OK with 2.2

On 2.3 and OpenHabian 1.4.1 you need to add “modbus binding” to install gnu.io also :slightly_smiling_face:

On OpenHab 2.3:

karaf bundle:list

227 │ Installed │ 80 │ 2.3.0.b5 │ OpenWebNet Binding (beta5)

but I’m not able to find it in the webpages (Paper-UI); on log i find:

2018-05-29 21:59:37.825 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/THE_PATH/openhab-2.3.0/addons/org.openhab.binding.openwebnet-2.3.0-b5.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.openwebnet [227]
_ Unresolved requirement: Import-Package: gnu.io_

On OpenHabian 1.4.1:

2018-05-30 00:07:03.550 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.openwebnet-2.3.0-b5.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.openwebnet [224]
Unresolved requirement: Import-Package: gnu.io

Hello All,
I’m deleted the automation actuators Legrand 067263
My first shutter actuator is recognize on GENERIC Device (WHERE=765215901#9)
OpenWebNet Generic Device
My second shutter actuator is recognise GENERIC Device (WHERE=765217301#9)
OpenWebNet Generic Device
So I added the actuators manually.
Orders “up” and “down” are always reversed

Some time ago I used this binding and it worked well
Link for this binding : Upgrade BTICINO (OpenWebNet) binding to OH2 (plus new Zigbee GW support)

Best regards

Hi Arnaud (@tagada),

  • for the discovery as GENERIC I need to check the device code your shutters returns, maybe is a new one and I can add it
  • for the inverted UP/DOWN : this is very strange as the OpenWebNet documentation is quite clear and for others it works well.

To sort both things out I would need your log.
Please proceed this way:

  1. set log level to DEBUG:
    • from Karaf console (more info here):
      • log:set DEBUG org.openhab.binding.openwebnet
      • log:set DEBUG org.openwebnet
  2. delete the automation actuators
  3. stop openhab
  4. start openhab
  5. start a new discovery
  6. add manually one of the 2 shutter actuators
  7. on PaperUI press the down arrow “v” to close your shutter

and then send the openhab.log file, better if you use a personal message (PM).


Ciao Massimo,

it seems almost OK with this beta but I’ve found those in the log:

2018-05-30 07:58:47.034 [INFO ] [et.handler.OpenWebNetLightingHandler] - ==OWN:LightingHandler== updateLightOnOffState() Ignoring unsupported WHAT for thing openwebnet:bus_on_off_switch:4005f1b5:88h4h03. Frame=<°1°39°88#4#03##>
updateLightOnOffState() Ignoring unsupported WHAT for thing openwebnet:bus_on_off_switch:4005f1b5:88h4h03. Frame=<°1°34°88#4#03##>

If you remember we just saw it and I realize today what’s this device… It is a device by Bticino, exactly this:

AM5658 Green Switch: integrated control with movement sensor, using a combination of passive infrared rays and ultrasounds, and brightness sensor. Manual switching ON of the light using the front pushbutton, and automatic switching off based on brightness level and movement. Switch off delay and brightness sensor threshold adjustable using the the one-two-way remote control (BMSO4003 and BMSO4001), physical or virtual configuration. 2 modules

Every time it is triggered “on” by movement it turns on some lights it sends on bus Frame=<°1°34°88#4#03##> , when timer expires (and turns off lights) it sends Frame=<°1°39°88#4#03##>

Are you interested in manage this?

PS: note I changed “star” in " ° "


Hi @Rob-VF

  • the dependency to gnu.io is already included in the binding, nothing changed on that side in the binding; so probably something is broken in dependency management in the new OH v2.3.0 just released. I will investigate more… thanks for pointing it out!

  • the WHO generated by the device is in fact documented. I do not have that device. If you plan to use it in OH2, then please file an issue here: https://github.com/mvalla/openhab-openwebnet so that it is tracked and maybe also others could contribute to it.


I can confirm Rob-VF described behaviour, after the update the binding is not showing anymore.
But using the “modbus workaround” everything seems working again (no need to reconfigure anything)


hello everyone!
i’ve tried to install Modbus Binding (binding-modbus1 - 1.12.0) from PaperUI, then i’ve logged by ssh directly from raspberry using (ssh -p 8101 openhab@localhost), then executed the command “feature:install openhab-transport-serial”, installed Bticino binding, but i still cannot see in bindings the bticino binding as installed, and also i cannot see in homekit my blinds…how can i solve it?
please explain as you could explain to a child :slight_smile: thanks a lot

This is what I did:
1 Copy and paste the binding file into the addons folder
2 install modbus from addons bindings in paper ui
3 restart openhab
4 in inbox start a new manual discovery: you should see the openwebnet binding and be able to add your gateway


Grazie Enrico!

Just one little question…can you link me the binding file to be moved to addons folder?

Thanks a lot!

Ruben Fuser

first post of this thread:

ok i can see the binding in PaperUI…but from Homekit i still cannot see blinds.
is it possible to download the previous version of “Bticino Binding” ? where can i find it?


Hi @rubenfuser,
did you configure the gateway manually?
did you start a discovery afterwards to discover devices?
Please first of all follow instructions as detailed in the binding README.

Previous beta4 (b4) version of the binding can be found here, but it does not support shutters/blinds.


for the moment i’m testing configuration files without connecting directly to my Bticino LCD panel…
what i’m doing is, install openhab, install bticino binding from add-ons in paperui, install homekit plugin, add bticino.items and check from my iphone if homekit can see all peripherals added in bticino.items.
i can see all lights, but not blinds.
Yesterday morning worked perfectly, but after lunch (around 14 pm italy time) i’ve reinstalled everything clean, and it started to not show only blinds. but i’m sure with the same config file, in the morning worked perfectly…i’m becoming crazy :’(

Can you look at PaperUI/Configuration>Bindings ? I suspect you have installed the official BTicino1 binding. This thread is about the under development OpenWebNet(BTicino) binding which cannot be installed via paperUI (yet) as it is not yet part of the official release…

In relation to HomeKit configuration, I suggest you look for other thread in the community/guides for proper configuration.


oh yes sorry, i thought this page was for BTicino Binding (binding-bticino1 - 1.12.0)

For blind control it seems Alexa only responds to 0% or 100%. She says the devices cant do ‘stop’. Is this an issue of the BUS binding or Alexa? Stop works from the control panel. Also, Alexa doesn’t seem to able to do open, close, up, down either. I posted the same question on the Echo control thread as I am not sure where the issue is.

2nd small issue… The discovery refused to find one of my lights. After a few tries I manually added and it works. It’s a dimmer and was on during the search. @massi it’s address 9.2 if you want to check the logs. Lights with addresses either side were found.