[BTicino/OpenWebNet] New openHAB2 binding ready for testing

Tags: #<Tag:0x00007f7450af2c08> #<Tag:0x00007f7450af2b40> #<Tag:0x00007f7450af2a50>

yes, i have read the first message, but i don’t understand how i have to procede.
I have created a new scenario in mh202 (cen+ 1), that power on the amplifier in the kitchen. Now how i can add item in openhab for manage it?

How i can send cen+ command on the bus?

Hi Massimo,
I had the old M3 that Michele had passed me.
Everything worked well, but the raspberry started again the other day and no longer communicated with the gateway. I updated with this last one of yours, but the thermoregulation, however, returned with the problem that existed before the M3 given to me by Michele. With this there is still the problem of changing modes in Manual mode: in practice, if I switch from Protection or from Auto to Manual mode, until the temperature increases or decreases the mode remains the one previously set (it does not change the mode if I do not change temperature , so I happened to find the house cold because not changing temperatures the probe did not actually switch to Manual mode, remaining in Protection). I hope I explained myself well, Michele had already solved the problem on the previous release that we only had him, and Stefan, but now I see that the one you published does not have the changes you had entered on my report. Can you fix it?

Thank you and good day,
Emiliano.

Hello
I have some problem when installing the openwebnet binding. I follow instructions but I have this messasage " [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.openwebnet-2.5.0.M3.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.openwebnet [234]"

Have you an idea to solve this problem.
Regards

Just a check: already done from Karaf console feature:install for dependecies?

Thanks Marco for your response

I’m not familiar with karaf console, please give more details for installing dependecies.

Regards.

Hey guys,

i have a fresh openhabian install with the current milestone testing build of openhab.
I get this problem when i want to install the feature:

Error executing command: No matching features for esh-io-transport-upnp/0

Any ideas how to solve this?

I cannot confirm it’s the right way but, the following solved my installation:
feature:install openhab-transport-serial and openhab-core-io-transport-upnp

Good Morning all,

If I possess the server F454 and the myhome screen, can I setup a shutter run or not ? It’s not clear to me

If yes, how should I proceed ?
thx

what do you mean by “shutter run”?

Shutter run as explain in the readme file. To be able to know the position of the blind

ok, so yes you can do that.
It’s exactly the process described in the readme: you can manually set the time needed for the roller shutter to open and close or make the system do the calculation by putting “auto”.
I strongly suggest to put it manually

Hi, there are a way for send a openwebnet command to the bus?
For example, if i send this command to the bus:
163*22##
i poweron the audio amplifie rin the pc. Can i do it? In what way?

i, i have created a new scenario, that poweron amplifier of audio diffusion. I have configurated this scenario for start whit:
CEN A:8 PL: 1 BUTTON: 0

And another scenario cen plus that start with

Cen+:10 button1

How i can create a item for simulate the pression of this button? I don’t understand, can you help me?

Topic Controls

I update my sistuation. I need to add a button in my sitemap for activate the cen+ scenario:
CEN PLUS 1, BUTTON 9 (PRESSED)

I don’t have write line in mi thing file, it is void, i have addedd an item from PAPER UY, then i have do:
INBOX -> + -> OpenWebNet binding -> ADD MANUALLY -> CEN+ Scenario Control
Then i have configurated it in this way:
Configured buttons: 9
Where: 21

In this way, i see it in PAPER UI -> CONTROL
If i click on it, scenario start. Now i need to add item in my item file, and then in sitemap for control it from my sitemap.

Then i go to “edit CEN+ Scenario Control”, and i see this row:
openwebnet:bus_cenplus_scenario_control:d9a44ed1:button_9

Then i add in item file:
String cenplus "Accendi luci cenplus" <network> {cannel="openwebnet:bus_cenplus_scenario_control:d9a44ed1:button_9"}
and in sitemap:
Switch item=cenplus label="cen plus []" mappings=[pressed="PRESSED"]

Why it not work? If it work from paper UI, i need to add a line in things file? If yes, what i have to add, if i don’t have a row for configuration of openwebnet binding? (I have configurated it from paper ui…)

Hy guys, I’m sorry for my english. I’ve installed OpenWebNet binding.
I have a problem with my inbox: i don’t find OpenWebNet binding. Why i don’t find it?
Thanks for answers

Hi @djmirco and welcome to the openHAB community!
Did you read carefully the README_beta instructions for installing the binding?
In particular the dependencies to be activated are:

  • feature:install openhab-transport-serial
  • and then
    • for openHAB 2.4.x:
      • feature:install esh-io-transport-upnp
    • or for openHAB 2.5.x and later:
      • feature:install openhab-core-io-transport-upnp

Hi massi. Thank you very much. I did it. Grazie 1000

@enrico.mcc thank you. I didn’t try shutterrun yet.
First of all I had to configure all things, items, sitemap properly.
Next step is shutter and try out some scenarios

@massi
Hi, By chance in the latest openwebnet version there are roller problems?
Has the structure of the code been changed?
My installation includes openhabian 1.5 on rasp pi3 B and stable verisone openhab 2.4

To make it work on Google Assistant I had to configure the roller with simple mode.