[BTicino/OpenWebNet] New openHAB2 binding ready for testing

it makes me proud if my example is usefull for the readme, of course you can add it :+1:

Thanks Stefan and Massimo!
Unfortunately I can’t test it right now. Anyway I use the commands to the 3550 to load a program with lower temperatures when I’m not at home (program 1102) and to switch it off, when I’m away for more time.
The command I send is 41101*#0## (asterisk 4 asterisk 1101…)

(post withdrawn by author, will be automatically deleted in 96 hours unless flagged)

Hi Massimo, I’m now approaching the openhab and raspberry world. I installed on raspberry pi3 b, the pre-configured image of OpenHab and later, your building “openwebnet”, with some difficulty, given the first steps in this world, but I managed a distant dialogue my home automation system with the rasp, I can manage the lights … I have a problem, not so how to solve. First of all I want to point out that I came across this world, to be able to use my home automation system through google home. With this premise, return to the problem, which concerns the configuration with google home. I installed my work service, run the configuration and the device online, it also becomes my google home,
I could not even find the sitemap. From the Android app “openhab” in the Home, I have the Things and I can manage all the lights, both locally and from the cloud, but I only have all the “actuators” I do not have the division by groups / house plan etc. and also I did not understand how to create scenarios.
I hope I have been clear and I hope for help.

hi nicola,

groups you have to define in your items-file. for example like this:

Group Home "MyHome" <house>

Group AH "Outside" <garden> (Home)

Group EG "Groundfloor" <groundfloor> (Home)

Group EG_Flur "Corridor" <corridor> (Home, EG)

Group AH_Garten "Garden" <garden> (Home, AH)

Dimmer EG_Li_Flur "Spots [%.0f %%]" <DimmableLight> (EG_Flur) {channel="openwebnet:bus_dimmer:MH200N:EG_Li_Flur:brightness"}

Switch EG_Li_FlurDekolampe "Dekolampe" (EG_Flur) {channel="openwebnet:bus_on_off_switch:MH200N:EG_Li_FlurDekolampe:switch"}

Switch AH_Li_TerrasseKugeln "Leuchtkugeln" (AH_Garten) {channel="openwebnet:bus_on_off_switch:MH200N:AH_Li_TerrasseKugeln:switch"}

Switch AH_Li_PoolLED "LED-Beleuchtung" (AH_Garten) {channel="openwebnet:bus_on_off_switch:MH200N:AH_Li_PoolLED:switch"}

scenarios are implemented not yet!

and for google i cannot help, sorry.

So finally, I had time to install the binding! Hadn’t any difficulty in doing it.
The discovery of the things is great.
Rollershutter are working great. But when I send a percentage like “sendCommand(Tapp1, 20)” it goes first to that percentage and then to 100…
Regarding the 3550 I don’t see anything in the logfile as I don’t have any item. With the 1.12 binding I had that item {bticino=“if=webserver;who=4;what=100;where=2”}
How should I define it here?

Thank you very much

Good that things work!

Did you first calibrate the rollershutters as described in the README ?
For percent commands to work, a complete calibration must be performed first either automatic or by inserting the shutterRun duration of a full run.

Each thermostat in your system should be discovered by the binding, so you should have found a WHERE=2 thermostat in your Inbox. The central unit is not supported for now in the binding, so for example you cannot change setpoint temp for all your thermostats at once, but still you can group your thermostats in a OH group and obtain the same behaviour…
Also WHAT=100 does not look like a valid parameter for Thermo function.


Actually yes. But maybe something went wrong, so I will try again.

My major utilization of OpenHab are rules regarding the central unit, using programs to change temperature of rooms that are different per room and depending also on the time of day. Programs changes depending on if somebody is at home, left the appartment or we are on vacation. This is really usefull as we have classical radiators so playing with temperature depending on the hour of day and considering also our habits makes a lot of sense.
Doing it on every thermostat would generate a huge automation file, that for now is also quite long (450 lines more or less)
When do you think will that implemented?

Thank you very much!

After CEN, CEN+ and contact sensors integration is done :grinning: Hopefully :grinning:

At the moment Openhab can’t quite replace my other apps and software because it can’t initiate or react to scenarios directly nor contact sensors.

One way forward is to add dummy BUS switches and then have CEN, CEN+ and contact sensors utilise these dummy switches in scenarios. I have done that with some important scenarios but I would need to add a lot more dummy switches on the BUS to get all working in Openhab and obviously that’s wasteful and expensive.

Tried again to calibrate, but with the same result. I send for example “sendCommand(Tapp1, 60)” while it was open and closes completly anyway. I tried also to insert manually a much lesser value, but same result.
I have a warning in my log file:
[.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <21000#0*49##> NOT SUPPORTED for thing openwebnet:bus_automation:19f17d45:49, ignoring it.

[.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <21000#1*49##> NOT SUPPORTED for thing openwebnet:bus_automation:19f17d45:49, ignoring it.



@massi… For documentation… I have the binding working with these radio devices:

Blind/Light actuator wireless bridge:
Transmitter HD4576
Actuator BT H4573/2

External temperature probe:
Probe 3455
Receiver N4577

They were not discoverable and I manually created a Thing for them


Hello Massi, thanks for the great job you’re doing.

Is it possible to donate some to pay a coffee at least?


good idea roberto,
massimo already spent much time and i think he earned a little tribute. pls let us know how to donate
best, stefan


Sorry if it’s a dump question, but i’l new to openhab (installed it today on my Rpi).
I’m trying to install this add-on, but can’t get it to work,
So far i did the following:

Make sure that the [marketplace plugin is activated]
and then tried to install the OpenWebNet binding from PaperUI (Add-ons -> Bindings -> search for ‘openwebnet’ then INSTALL). but i could not find it.


I Downloaded the latest released JAR file
and Copy the JAR file to /usr/share/openhab2/addons/

tried this
from [Karaf console] feature:install openhab-transport-serial`
and got this error:
-bash: feature:install: command not found

Can anyone point me in the right direction?

Thank you

the feature:install is not a linux command, you have to enter karaf-console first:

ssh -p 8101 openhab@localhost


when you entered karaf you even can check if the “openwebnet binding” is in this list:


then install gateway manually as described in readme and then you can run a device-discovery :slight_smile:


thank you for your reply, so in this screen:

I have to type this:
<ssh -p 8101 openhab@localhost>

I’ll try this this evening.

But why can’ ti see the plugin in the Marketplace?

yes, do that to enter karaf and then continue with feature:install … and budle:list to check

don´t know the reason but binding cannot be installed unter “addons”


I recently tried the market place and couldn’t see the binding in the addons list either. I gave up and installed it via jar file. Also, to enter Karaf console I type this in the already open linux console

openhab-cli console
password habopen
Sometimes it take a little while to get the prompt for the password.

Hi @jpcolin,
Have you set in Configuration->System under Marketplace “Include Bindings” and Maturity level to Alpha?

No it is set to beta, the openweb add-on is beta isn’t it?
I’ll try with alpha…